aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2021-01-01 08:58:06 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2021-01-01 08:58:19 +0000
commitf683e775ab8dc3fa43c250553613de05b2e0265e (patch)
treecf256b69d3f3f4971dc950fd4ef0d5b774f048ab
parent5c1dd9fe823bb942195ab4f0f9f8ef15000841ea (diff)
main/cifs-utils: upgrade to 6.12
-rw-r--r--main/cifs-utils/APKBUILD14
-rw-r--r--main/cifs-utils/libcap-0.8.1-1.patch43
-rw-r--r--main/cifs-utils/libcap-0.8.1-2.patch43
-rw-r--r--main/cifs-utils/path-install.patch17
4 files changed, 4 insertions, 113 deletions
diff --git a/main/cifs-utils/APKBUILD b/main/cifs-utils/APKBUILD
index 8181b047d27..836599ab178 100644
--- a/main/cifs-utils/APKBUILD
+++ b/main/cifs-utils/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=cifs-utils
-pkgver=6.11
-pkgrel=1
+pkgver=6.12
+pkgrel=0
pkgdesc="CIFS filesystem user-space tools"
url="https://wiki.samba.org/index.php/LinuxCIFS_utils"
arch="all"
@@ -13,9 +13,6 @@ subpackages="$pkgname-doc $pkgname-dev"
source="https://ftp.samba.org/pub/linux-cifs/cifs-utils/cifs-utils-$pkgver.tar.bz2
musl-fix-includes.patch
xattr_size_max.patch
- path-install.patch
- libcap-0.8.1-1.patch
- libcap-0.8.1-2.patch
"
options="suid"
@@ -47,9 +44,6 @@ package() {
chmod +s $pkgdir/sbin/mount.cifs
}
-sha512sums="064c0ac75572fb44908390508462e4fdfe0686751149fd8b656a209dd961a5a24a7d9774c38c0e72fa5f9875b43aea7bf2de038c4e4a63a11664e71d9003100e cifs-utils-6.11.tar.bz2
+sha512sums="2f2e1cba8d56c9039fc28236fa63812a09f07f14931c3bd7bd5ae3e6aeb372130c5a059569d8714fb973bea87eba394fd30228fbaeabe700961bba400dd01ca6 cifs-utils-6.12.tar.bz2
99a2fab05bc2f14a600f89526ae0ed2c183cfa179fe386cb327075f710aee3aed5ae823f7c2f51913d1217c2371990d6d4609fdb8d80288bd3a6139df3c8aebe musl-fix-includes.patch
-2a9366ec1ddb0389c535d2fa889f63287cb8374535a47232de102c7e50b6874f67a3d5ef3318df23733300fd8459c7ec4b11f3211508aca7800b756119308e98 xattr_size_max.patch
-2c44eab140eec13f4e6c36c1fd3d0961af01baa867b16011fb2241718eb1c785660bd874dc845213161e058341cee6fd5fdb7487b7f7731cf1886fd73597924d path-install.patch
-aa2172b0c66da4341e10f52710fcd696839b40568662fbd6352a1ba4465bce2cd57f7721f8ee246b60afede73c7c0c71d40921b285f00fbbb78d0ca92bad7c2e libcap-0.8.1-1.patch
-c3974aa1a4e25496a137095ad69f400ae0cae083684db9d44b89f59270250105ecdbaf1cfa991b314ca7bf648e837429743a71a2a930e373965bbc3c5050d40e libcap-0.8.1-2.patch"
+2a9366ec1ddb0389c535d2fa889f63287cb8374535a47232de102c7e50b6874f67a3d5ef3318df23733300fd8459c7ec4b11f3211508aca7800b756119308e98 xattr_size_max.patch"
diff --git a/main/cifs-utils/libcap-0.8.1-1.patch b/main/cifs-utils/libcap-0.8.1-1.patch
deleted file mode 100644
index 40c45ce9067..00000000000
--- a/main/cifs-utils/libcap-0.8.1-1.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-libcap-ng 0.8.1 tightened the error checking on capng_apply, returning an error
-of -4 when trying to update the capability bounding set without having the
-CAP_SETPCAP capability to be able to do so. Previous versions of libcap-ng
-silently skipped updating the bounding set and only updated the normal
-CAPNG_SELECT_CAPS capabilities instead.
-
-Check beforehand whether we have CAP_SETPCAP, in which case we can use
-CAPNG_SELECT_BOTH to update both the normal capabilities and the bounding set.
-Otherwise, we can at least update the normal capabilities, but refrain from
-trying to update the bounding set to avoid getting an error.
-
-Signed-off-by: Jonas Witschel <diabonas@archlinux.org>
----
- mount.cifs.c | 7 ++++++-
- 1 file changed, 6 insertions(+), 1 deletion(-)
-
-diff --git a/mount.cifs.c b/mount.cifs.c
-index 4feb397..88b8b69 100644
---- a/mount.cifs.c
-+++ b/mount.cifs.c
-@@ -338,6 +338,8 @@ static int set_password(struct parsed_mount_info *parsed_info, const char *src)
- static int
- drop_capabilities(int parent)
- {
-+ capng_select_t set = CAPNG_SELECT_CAPS;
-+
- capng_setpid(getpid());
- capng_clear(CAPNG_SELECT_BOTH);
- if (parent) {
-@@ -355,7 +357,10 @@ drop_capabilities(int parent)
- return EX_SYSERR;
- }
- }
-- if (capng_apply(CAPNG_SELECT_BOTH)) {
-+ if (capng_have_capability(CAPNG_EFFECTIVE, CAP_SETPCAP)) {
-+ set = CAPNG_SELECT_BOTH;
-+ }
-+ if (capng_apply(set)) {
- fprintf(stderr, "Unable to apply new capability set.\n");
- return EX_SYSERR;
- }
---
-2.29.2
diff --git a/main/cifs-utils/libcap-0.8.1-2.patch b/main/cifs-utils/libcap-0.8.1-2.patch
deleted file mode 100644
index fb54e6d9542..00000000000
--- a/main/cifs-utils/libcap-0.8.1-2.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-libcap-ng 0.8.1 tightened the error checking on capng_apply, returning an error
-of -4 when trying to update the capability bounding set without having the
-CAP_SETPCAP capability to be able to do so. Previous versions of libcap-ng
-silently skipped updating the bounding set and only updated the normal
-CAPNG_SELECT_CAPS capabilities instead.
-
-Check beforehand whether we have CAP_SETPCAP, in which case we can use
-CAPNG_SELECT_BOTH to update both the normal capabilities and the bounding set.
-Otherwise, we can at least update the normal capabilities, but refrain from
-trying to update the bounding set to avoid getting an error.
-
-Signed-off-by: Jonas Witschel <diabonas@archlinux.org>
----
- cifs.upcall.c | 7 ++++++-
- 1 file changed, 6 insertions(+), 1 deletion(-)
-
-diff --git a/cifs.upcall.c b/cifs.upcall.c
-index 1559434..af1a0b0 100644
---- a/cifs.upcall.c
-+++ b/cifs.upcall.c
-@@ -88,6 +88,8 @@ typedef enum _sectype {
- static int
- trim_capabilities(bool need_environ)
- {
-+ capng_select_t set = CAPNG_SELECT_CAPS;
-+
- capng_clear(CAPNG_SELECT_BOTH);
-
- /* SETUID and SETGID to change uid, gid, and grouplist */
-@@ -105,7 +107,10 @@ trim_capabilities(bool need_environ)
- return 1;
- }
-
-- if (capng_apply(CAPNG_SELECT_BOTH)) {
-+ if (capng_have_capability(CAPNG_EFFECTIVE, CAP_SETPCAP)) {
-+ set = CAPNG_SELECT_BOTH;
-+ }
-+ if (capng_apply(set)) {
- syslog(LOG_ERR, "%s: Unable to apply capability set: %m\n", __func__);
- return 1;
- }
---
-2.29.2
diff --git a/main/cifs-utils/path-install.patch b/main/cifs-utils/path-install.patch
deleted file mode 100644
index 02a464073dd..00000000000
--- a/main/cifs-utils/path-install.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff --git a/Makefile.am b/Makefile.am
-index fe9cd34..6ab4b01 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -119,10 +119,10 @@ endif
- SUBDIRS = contrib
-
- install-exec-hook:
-- (cd $(ROOTSBINDIR) && ln -sf mount.cifs mount.smb3)
-+ (cd $(DESTDIR)$(ROOTSBINDIR) && ln -sf mount.cifs mount.smb3)
-
- install-data-hook:
-- (cd $(man8dir) && ln -sf mount.cifs.8 mount.smb3.8)
-+ (cd $(DESTDIR)$(man8dir) && ln -sf mount.cifs.8 mount.smb3.8)
-
- uninstall-hook:
- (cd $(ROOTSBINDIR) && rm -f $(ROOTSBINDIR)/mount.smb3)