aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-08-10 10:56:24 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-08-10 14:17:23 +0000
commitf6c80de05e763d4cee2a06bd62fc0b012ead19f0 (patch)
tree1adb5d41a2c2c08c168e5db96975f5f7018e67a6
parentd19c68d61ea064e4d55a6fed068785c547582d3c (diff)
testing/luakit: upgrade to 2.2
-rw-r--r--testing/luakit/APKBUILD11
-rw-r--r--testing/luakit/tests.patch55
2 files changed, 5 insertions, 61 deletions
diff --git a/testing/luakit/APKBUILD b/testing/luakit/APKBUILD
index ffd4de58798..9352498ec6f 100644
--- a/testing/luakit/APKBUILD
+++ b/testing/luakit/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer:
pkgname=luakit
-pkgver=2.1
-pkgrel=2
+pkgver=2.2
+pkgrel=0
pkgdesc="Fast, small, webkit based browser framework extensible by Lua"
url="https://luakit.github.io/"
arch="all !mips !mips64 !s390x" #fixme install fails on s390x
@@ -14,7 +14,7 @@ options="!check" #fixme
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/luakit/luakit/archive/$pkgver.tar.gz
config-mk.patch
- tests.patch"
+ "
build() {
make PREFIX=/usr USE_LUAJIT=1 DEVELOPMENT_PATHS=0
@@ -31,6 +31,5 @@ package() {
rmdir "$pkgdir"/usr/share/"$pkgname"/doc
}
-sha512sums="1daee7fe4bf5fad0f2c70d714c316914c601467facafdb22e4f27c18a691e249cefd5680ede834bcc555041afdc5d7e70610e2cd5e33db1ad8d9f2fe0327ccac luakit-2.1.tar.gz
-d852a17bf202b18e75bda3885e421a957ce501ebbeb0ecd6e7a6379747e350878c9f95683a0385ce9daa719ddd02a3e5d5143ebd9ee892a469d8457e7a863b5a config-mk.patch
-6d0b3a93b7bedcdd3ebe7283d734d013aa25683a9effc841f4a57aa8f2ea34dc68dc4bd35a22436d28e4011c60243047b72ff8d81affb349912de43e1e20232f tests.patch"
+sha512sums="5364acc559c934593dd9d66f8f3238225a7f89a824780f406a0a616d89fc78db4ee98b2cfa161e43ffbdfb9c5ac915a63383f45b1b6bd4eda9c33d62eff2b06f luakit-2.2.tar.gz
+d852a17bf202b18e75bda3885e421a957ce501ebbeb0ecd6e7a6379747e350878c9f95683a0385ce9daa719ddd02a3e5d5143ebd9ee892a469d8457e7a863b5a config-mk.patch"
diff --git a/testing/luakit/tests.patch b/testing/luakit/tests.patch
deleted file mode 100644
index 3d9763f0d46..00000000000
--- a/testing/luakit/tests.patch
+++ /dev/null
@@ -1,55 +0,0 @@
---- a/clib/soup.c
-+++ b/clib/soup.c
-@@ -106,7 +106,7 @@ luaH_soup_set_cookies_storage(lua_State *L)
- luaL_error(L, "cookies_storage cannot be empty");
- g_free(cookies_storage);
- cookies_storage = g_strdup(new_path);
--
-+
- if ((f = g_fopen(cookies_storage, "a")) != NULL) {
- g_chmod(cookies_storage, 0600);
- fclose(f);
---- a/lib/binds.lua
-+++ b/lib/binds.lua
-@@ -496,7 +496,7 @@ modes.add_cmds({
- callback = function (_, err)
- w:error(err)
- end,
-- })
-+ })
- else
- w:error("No argument provided")
- end
---- a/lib/help_chrome.lua
-+++ b/lib/help_chrome.lua
-@@ -27,7 +27,8 @@ local index_html_template = [==[
- </style>
- </head>
- <body>
-- <header id="page-header"><h1>Luakit Help</h1><div class="rhs">version {version} / webkit {webkitversion}</div></header>
-+ <header id="page-header"><h1>Luakit Help</h1><div
-+ class="rhs">version {version} / webkit {webkitversion}</div></header>
- <div class=content-margin>
- <h2>About Luakit</h2>
- <p>Luakit is a highly configurable, browser framework based on the <a
---- a/tests/async/test_module_binds_have_descriptions.lua
-+++ b/tests/async/test_module_binds_have_descriptions.lua
-@@ -47,6 +47,7 @@ local function add_file_error(errors, file, error, ...)
- end
-
- T.test_module_binds_have_descriptions = function ()
-+ require("newtab_chrome")
- local files = test.find_files({"lib/"}, ".+%.lua$", {"_wm%.lua$", "modes%.lua", "unique_instance%.lua"})
-
- local errors = {}
---- a/tests/lib.lua
-+++ b/tests/lib.lua
-@@ -115,7 +115,7 @@ function _M.wait(timeout)
- shared_lib.traceback = debug.traceback("",2)
-
- waiting = true
-- timeout = timeout or 200
-+ timeout = timeout or 1000
- return coroutine.yield({timeout=timeout})
- end
-