aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2021-04-05 16:03:07 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2021-04-05 18:19:36 +0000
commitf7619c1c3f28e0abb778782884a85caaa20a4ef1 (patch)
tree1eeed006d44cbaef993224d2878e7a73168ec100
parent89c8a30060e7a41acb153cf30b0d620d68a21870 (diff)
testing/py3-sphinx-theme-better: fix source url / build with python 3.9
-rw-r--r--testing/py3-sphinx-theme-better/APKBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/testing/py3-sphinx-theme-better/APKBUILD b/testing/py3-sphinx-theme-better/APKBUILD
index f51aa0bdde6..f670394e50c 100644
--- a/testing/py3-sphinx-theme-better/APKBUILD
+++ b/testing/py3-sphinx-theme-better/APKBUILD
@@ -3,22 +3,26 @@
pkgname=py3-sphinx-theme-better
_pkgname=sphinx-better-theme
pkgver=0.1.5
-pkgrel=1
+pkgrel=2
pkgdesc="The Better Sphinx theme"
url="https://github.com/irskep/sphinx-better-theme"
arch="noarch"
license="BSD-2-Clause"
depends="py3-sphinx"
makedepends="py3-setuptools"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/irskep/sphinx-better-theme/archive/refs/tags/v$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
build() {
python3 setup.py build
}
+check() {
+ python3 setup.py check
+}
+
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="06e50079967e166d5daf58a44c18e477cfc71d326ecf2e0a5932200c911e73ee188f720fd5bd15c2e298e14f7e3358e02e94381470bb7958edb0b0aed334ef9c sphinx-better-theme-0.1.5.tar.gz"
+sha512sums="057c0f0c57fa7a9637997f22ba9931844020ba537f5eafaf9504352fe6ae70fc2d10c0dc6fb06f8ab31c45d7cf4760e9e3047aaaa105060af4ead04de31c8af1 py3-sphinx-theme-better-0.1.5.tar.gz"