aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-01-02 16:24:56 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-01-02 16:32:06 +0000
commitf9c421d60809483251cc373c762e0a8293ee697b (patch)
tree07438f939f07a368a768ca3c76c6411f137b9395
parent2a5b65245fc99d4756d8316c3deb1816d37db412 (diff)
testing/ratpoison: fix license, depends and check
-rw-r--r--testing/ratpoison/APKBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/testing/ratpoison/APKBUILD b/testing/ratpoison/APKBUILD
index 2671f4408c3..e6c275e18dd 100644
--- a/testing/ratpoison/APKBUILD
+++ b/testing/ratpoison/APKBUILD
@@ -2,18 +2,15 @@
# Maintainer: Duncan Guthrie <dguthrie@posteo.net>
pkgname=ratpoison
pkgver=1.4.9
-pkgrel=0
-pkgdesc="ratpoison: Say good-bye to the rodent"
+pkgrel=1
+pkgdesc="Minimalistic window manager"
url="http://ratpoison.nongnu.org"
arch="all"
-license="GPL2"
-depends="libx11"
+license="GPL-2.0-only"
makedepends="libx11-dev"
-install=""
subpackages="$pkgname-dev $pkgname-doc"
source="http://download.savannah.nongnu.org/releases/$pkgname/$pkgname-$pkgver.tar.xz"
builddir="$srcdir/$pkgname-$pkgver"
-options="!check"
build() {
cd "$builddir"
@@ -30,6 +27,11 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install