aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKeith Maxwell <keith.maxwell@gmail.com>2020-04-12 10:12:45 +0100
committerKeith Maxwell <keith.maxwell@gmail.com>2020-04-12 10:28:46 +0100
commitfa3110cd954ec28919f1c4c2525d68bd16e424ef (patch)
tree9d294bb0a13af2a98c0b2e0677ac1c54aedaa684
parent9af72b19675b1be5e4f838b5dc97b5fa4d7211d0 (diff)
main/py3-wheel: add missing dependency
Before this change: $ dabuild sh $ sudo apk add py3-wheel >/dev/null && wheel --help Traceback (most recent call last): File "/usr/bin/wheel", line 6, in <module> from pkg_resources import load_entry_point ModuleNotFoundError: No module named 'pkg_resources' This change adds py3-setuptools as a runtime dependency because pkg_resources is imported by a file installed into /usr/bin/: $ grep pkg_resources /usr/bin/wheel from pkg_resources import load_entry_point pkg_resources is part of py3-setuptools: $ apk info -L py3-setuptools | grep pkg_resources/__init__.py usr/lib/python3.8/site-packages/pkg_resources/__init__.py After this change: $ dabuild sh $ sudo apk add py3-wheel >/dev/null && wheel -h usage: wheel [-h] {unpack,pack,convert,version,help} ... positional arguments: {unpack,pack,convert,version,help} commands unpack Unpack wheel pack Repack wheel convert Convert egg or wininst to wheel version Print version and exit help Show this help optional arguments: -h, --help show this help message and exit
-rw-r--r--main/py3-wheel/APKBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/main/py3-wheel/APKBUILD b/main/py3-wheel/APKBUILD
index b278363cc66..442d0e69490 100644
--- a/main/py3-wheel/APKBUILD
+++ b/main/py3-wheel/APKBUILD
@@ -1,16 +1,15 @@
# Contributor: Antoine Fontaine <antoine.fontaine@epfl.ch>
# Maintainer: Antoine Fontaine <antoine.fontaine@epfl.ch>
-pkgname="py3-wheel"
-_pyname="wheel"
-pkgver="0.34.2"
-pkgrel=0
+pkgname=py3-wheel
+_pyname=wheel
+pkgver=0.34.2
+pkgrel=1
pkgdesc="A built-package format for Python"
url="https://github.com/pypa/wheel"
arch="noarch"
license="MIT"
subpackages="$pkgname-doc"
-depends="python3"
-makedepends="py3-setuptools"
+depends="python3 py3-setuptools"
_pypiprefix="${_pyname%${_pyname#?}}"
source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
builddir="$srcdir"/$_pyname-$pkgver