aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-12-29 06:48:06 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-12-29 06:57:32 -0300
commitfbccd5cb500f7ad42fbf97124c99423761df9927 (patch)
tree05aea03d4d2fcac065b31050ef9e39c4fc53b1ea
parenteae1d85fb6da65520a34edf652ee7c6a5d5746cd (diff)
community/py3-gevent: use system c-ares and libev, remove tests
pass GEVENTSETUP_EMBED=0 so it uses the system libraries instead of their own vendoring
-rw-r--r--community/py3-gevent/APKBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/community/py3-gevent/APKBUILD b/community/py3-gevent/APKBUILD
index ffeab378ad3..342edea94a9 100644
--- a/community/py3-gevent/APKBUILD
+++ b/community/py3-gevent/APKBUILD
@@ -3,14 +3,14 @@
pkgname=py3-gevent
_pkgname=gevent
pkgver=1.5.0
-pkgrel=0
+pkgrel=1
pkgdesc="Python3 library for seamless coroutine-based concurrency"
options="!check" # Requires unpackaged 'objgraph'
url="http://gevent.org/"
arch="all"
license="MIT"
depends="py3-greenlet"
-makedepends="py3-setuptools python3-dev libevent-dev file cython"
+makedepends="py3-setuptools python3-dev c-ares-dev libevent-dev libev-dev file cython"
source="$pkgname-$pkgver.tar.gz::https://github.com/$_pkgname/$_pkgname/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -18,10 +18,14 @@ replaces="py-gevent" # Backwards compatibility
provides="py-gevent=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ export GEVENTSETUP_EMBED=0
+ CYTHON=cython PYTHON=python3 python3 setup.py build
}
package() {
+ export GEVENTSETUP_EMBED=0
python3 setup.py install --prefix=/usr --root="$pkgdir"
+
+ rm -rf "$pkgdir"/usr/lib/python3*/site-packages/*/tests
}
sha512sums="20460c2ff5822b4ccff27d616e94897f4edc19372d19aaf8cb00877449d1c899481bc0312839ee5b77a7166a61584e0f4f779dc81e437ebbd75e042db68d50ae py3-gevent-1.5.0.tar.gz"