aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorptrcnull <git@ptrcnull.me>2024-03-28 13:06:55 +0100
committerBart Ribbers <bribbers@disroot.org>2024-03-28 15:20:30 +0000
commit618b16df8e0842fbe42f95b604a2312332635591 (patch)
treeda237b9866fc96f4f801e6d3d8067267be639985
parent2f1433492025d9f20b6a480a3326ec6d083286c4 (diff)
community/py3-pyocd: fix tests with python 3.12HEADmaster
-rw-r--r--community/py3-pyocd/0003-Fix-missing-not_called.patch9
-rw-r--r--community/py3-pyocd/APKBUILD2
2 files changed, 11 insertions, 0 deletions
diff --git a/community/py3-pyocd/0003-Fix-missing-not_called.patch b/community/py3-pyocd/0003-Fix-missing-not_called.patch
new file mode 100644
index 00000000000..90a3b0faa63
--- /dev/null
+++ b/community/py3-pyocd/0003-Fix-missing-not_called.patch
@@ -0,0 +1,9 @@
+diff --git a/test/unit/test_autoflush.py b/test/unit/test_autoflush.py
+index 2579055..752ba35 100644
+--- a/test/unit/test_autoflush.py
++++ b/test/unit/test_autoflush.py
+@@ -37,3 +37,3 @@ class TestAutoflush:
+ raise TransferError("bad joojoo")
+- assert mock_obj.flush.not_called
++ mock_obj.flush.assert_not_called()
+
diff --git a/community/py3-pyocd/APKBUILD b/community/py3-pyocd/APKBUILD
index 0e31d90b2db..d43a146f362 100644
--- a/community/py3-pyocd/APKBUILD
+++ b/community/py3-pyocd/APKBUILD
@@ -37,6 +37,7 @@ subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/pyocd/pyOCD/archive/refs/tags/v$pkgver.tar.gz
0001-Make-use-of-libusb-package-optional.patch
0002-Add-uacess-to-udev.patch
+ 0003-Fix-missing-not_called.patch
"
builddir="$srcdir/pyOCD-$pkgver"
@@ -65,4 +66,5 @@ sha512sums="
26efd6ceeb0ddaea9ac52170082b9fd87926790f90c0d7ccb1deb9e9ec549b84202801704b65641e6a2ac7fe0215a540e45eb0e1a0b9a38ac373720c5884bd36 py3-pyocd-0.36.0.tar.gz
8255e1faec02474ca8d3db42e32f0d348c398953e690786b2a6ce417d1d700b93c91effb14ce64fe08f5e17fd5a602b2edac02de20858c5a62f255a323a93e83 0001-Make-use-of-libusb-package-optional.patch
132efcb19ee9d4cd4608f9e41a097ab292e7314b5589708a4398f81d727ad17b541047143d3f77628c5e1d70c404b4164625f81aa65a0bcdf6a76611ef09d74e 0002-Add-uacess-to-udev.patch
+4054a761b455051ee42afa0ceef55c0d11ee83d344342b587a5e14cc22da11e574d89c3e31905720094c925c5c99f266502a5754c58f6cdede090a71872dd15d 0003-Fix-missing-not_called.patch
"