aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJingyun Hua <huajingyun@loongson.cn>2024-03-28 12:43:45 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2024-03-29 11:40:01 +0000
commit3add37f3a9a86b35717f2cf7187158d28b328c2b (patch)
tree47a7261b7d686cffefa68dc83f442efb5c6d4e24
parente11cc0129c1f8051e44081ed1a436302d3f51249 (diff)
community/*: update config.{guess/sub} (based on loongarch64 needs)HEADmaster
-rw-r--r--community/agensgraph/APKBUILD5
-rw-r--r--community/alsa-tools/APKBUILD2
-rw-r--r--community/babeltrace/APKBUILD5
-rw-r--r--community/bird/APKBUILD5
-rw-r--r--community/bogofilter/APKBUILD6
-rw-r--r--community/cpptest/APKBUILD5
-rw-r--r--community/crun/APKBUILD6
-rw-r--r--community/dbus-test-runner/APKBUILD5
-rw-r--r--community/dhcp-probe/APKBUILD5
-rw-r--r--community/e2tools/APKBUILD5
-rw-r--r--community/enet/APKBUILD5
-rw-r--r--community/gnome-menus/APKBUILD6
-rw-r--r--community/ipmiutil/APKBUILD1
-rw-r--r--community/isync/APKBUILD5
-rw-r--r--community/libaacs/APKBUILD5
-rw-r--r--community/libdvdcss/APKBUILD1
-rw-r--r--community/libfilezilla/APKBUILD5
-rw-r--r--community/libfm-extra/APKBUILD5
-rw-r--r--community/libfm/APKBUILD5
-rw-r--r--community/libimobiledevice/APKBUILD4
-rw-r--r--community/libmatemixer/APKBUILD5
-rw-r--r--community/libqxp/APKBUILD5
-rw-r--r--community/libthreadar/APKBUILD5
-rw-r--r--community/libu2f-server/APKBUILD5
-rw-r--r--community/libunibreak/APKBUILD5
-rw-r--r--community/mbuffer/APKBUILD5
-rw-r--r--community/monitoring-plugins/APKBUILD5
-rw-r--r--community/pam-u2f/APKBUILD5
-rw-r--r--community/pilot-link/APKBUILD2
-rw-r--r--community/telepathy-mission-control/APKBUILD5
-rw-r--r--community/tpm2-tss-engine/APKBUILD5
-rw-r--r--community/tpm2-tss/APKBUILD5
-rw-r--r--community/udftools/APKBUILD1
-rw-r--r--community/unrtf/APKBUILD5
-rw-r--r--community/vorbis-tools/APKBUILD6
-rw-r--r--community/wavemon/APKBUILD5
-rw-r--r--community/wpan-tools/APKBUILD5
37 files changed, 170 insertions, 0 deletions
diff --git a/community/agensgraph/APKBUILD b/community/agensgraph/APKBUILD
index e6aa6e8af15..c4e17a2d85c 100644
--- a/community/agensgraph/APKBUILD
+++ b/community/agensgraph/APKBUILD
@@ -70,6 +70,11 @@ _datadir=usr/share/$pkgname
_includedir=usr/include/$pkgname
_libdir=usr/lib/$pkgname
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
build() {
export PYTHON=/usr/bin/python3
export CFLAGS="${CFLAGS/-Os/-O2}"
diff --git a/community/alsa-tools/APKBUILD b/community/alsa-tools/APKBUILD
index 1abe7e1c284..315edec9cc2 100644
--- a/community/alsa-tools/APKBUILD
+++ b/community/alsa-tools/APKBUILD
@@ -15,6 +15,8 @@ source="https://alsa-project.org/files/pub/tools/alsa-tools-$pkgver.tar.bz2"
prepare() {
default_prepare
+ update_config_sub
+ update_config_guess
# Remove qlo10k1 package, only works with Qt2/Qt3
sed 's/qlo10k1//' -i Makefile
}
diff --git a/community/babeltrace/APKBUILD b/community/babeltrace/APKBUILD
index f21f4b4765f..238a687fbe4 100644
--- a/community/babeltrace/APKBUILD
+++ b/community/babeltrace/APKBUILD
@@ -16,6 +16,11 @@ source="https://www.efficios.com/files/babeltrace/babeltrace2-$pkgver.tar.bz2
"
builddir="$srcdir/babeltrace2-$pkgver"
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
build() {
# This package uses _init functions to initialise extensions. With
# --as-needed this will not work.
diff --git a/community/bird/APKBUILD b/community/bird/APKBUILD
index cbc3fd12220..dcb6653676e 100644
--- a/community/bird/APKBUILD
+++ b/community/bird/APKBUILD
@@ -23,6 +23,11 @@ case "$CARCH" in
s390x) options="!check";;
esac
+prepare() {
+ default_prepare
+ update_config_guess
+}
+
build() {
./configure --prefix=/usr \
--sysconfdir=/etc \
diff --git a/community/bogofilter/APKBUILD b/community/bogofilter/APKBUILD
index d76196674e9..1a035284653 100644
--- a/community/bogofilter/APKBUILD
+++ b/community/bogofilter/APKBUILD
@@ -11,6 +11,12 @@ makedepends="sqlite-dev"
subpackages="$pkgname-doc"
source="https://downloads.sourceforge.net/project/bogofilter/bogofilter-stable/bogofilter-$pkgver.tar.xz"
+prepare() {
+ default_prepare
+ update_config_sub
+ update_config_guess
+}
+
build() {
./configure --prefix=/usr \
--with-included-gsl \
diff --git a/community/cpptest/APKBUILD b/community/cpptest/APKBUILD
index 05ab2659fdc..65b6fd6db79 100644
--- a/community/cpptest/APKBUILD
+++ b/community/cpptest/APKBUILD
@@ -10,6 +10,11 @@ license="LGPL-2.0-or-later"
subpackages="$pkgname-dev"
source="https://github.com/cpptest/cpptest/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
+prepare() {
+ default_prepare
+ update_config_guess
+}
+
build() {
./configure --prefix=/usr
make
diff --git a/community/crun/APKBUILD b/community/crun/APKBUILD
index ddfc4a9bc4e..c8d938f6ce7 100644
--- a/community/crun/APKBUILD
+++ b/community/crun/APKBUILD
@@ -19,6 +19,12 @@ provider_priority=100 # highest, default provider
# 1.4.4-r0:
# - CVE-2022-27650
+prepare() {
+ default_prepare
+ update_config_sub
+ update_config_guess
+}
+
build() {
./configure \
--prefix=/usr \
diff --git a/community/dbus-test-runner/APKBUILD b/community/dbus-test-runner/APKBUILD
index 3147e62ec3f..94ba440d545 100644
--- a/community/dbus-test-runner/APKBUILD
+++ b/community/dbus-test-runner/APKBUILD
@@ -14,6 +14,11 @@ checkdepends="bash"
subpackages="$pkgname-dev $pkgname-libs"
source="https://launchpad.net/dbus-test-runner/${pkgver%.*}/$pkgver/+download/dbus-test-runner-$pkgver.tar.gz"
+prepare() {
+ default_prepare
+ update_config_guess
+}
+
build() {
./configure --prefix=/usr --disable-static
make
diff --git a/community/dhcp-probe/APKBUILD b/community/dhcp-probe/APKBUILD
index 6e765e6e4e7..17727eaef16 100644
--- a/community/dhcp-probe/APKBUILD
+++ b/community/dhcp-probe/APKBUILD
@@ -15,6 +15,11 @@ source="http://www.net.princeton.edu/software/$_pkgname/$_pkgname-$pkgver.tar.gz
$pkgname.confd"
builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ default_prepare
+ update_config_guess
+}
+
build() {
./configure --prefix=/usr
make
diff --git a/community/e2tools/APKBUILD b/community/e2tools/APKBUILD
index 1d53cc78fd6..65b07f2da75 100644
--- a/community/e2tools/APKBUILD
+++ b/community/e2tools/APKBUILD
@@ -12,6 +12,11 @@ checkdepends="e2fsprogs"
subpackages="$pkgname-doc"
source="https://github.com/e2tools/e2tools/releases/download/v$pkgver/e2tools-$pkgver.tar.gz"
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
build() {
./configure \
--build=$CBUILD \
diff --git a/community/enet/APKBUILD b/community/enet/APKBUILD
index 932f2a5574f..3c1738f2f50 100644
--- a/community/enet/APKBUILD
+++ b/community/enet/APKBUILD
@@ -11,6 +11,11 @@ license="MIT"
subpackages="$pkgname-dev"
source="http://enet.bespin.org/download/enet-$pkgver.tar.gz"
+prepare() {
+ default_prepare
+ update_config_guess
+}
+
build() {
./configure --prefix=/usr --disable-static
make
diff --git a/community/gnome-menus/APKBUILD b/community/gnome-menus/APKBUILD
index de32f17ff5a..ba99a8d5c16 100644
--- a/community/gnome-menus/APKBUILD
+++ b/community/gnome-menus/APKBUILD
@@ -12,6 +12,12 @@ subpackages="$pkgname-dev $pkgname-lang"
source="http://ftp.gnome.org/pub/gnome/sources/gnome-menus/${pkgver%.*}/gnome-menus-$pkgver.tar.xz"
options="!check" # No test suite
+prepare() {
+ default_prepare
+ update_config_sub
+ update_config_guess
+}
+
build() {
./configure \
--prefix=/usr \
diff --git a/community/ipmiutil/APKBUILD b/community/ipmiutil/APKBUILD
index 45219377208..5637c7d25ba 100644
--- a/community/ipmiutil/APKBUILD
+++ b/community/ipmiutil/APKBUILD
@@ -16,6 +16,7 @@ source="$pkgname-$pkgver-u.tar.gz::https://downloads.sourceforge.net/project/ipm
prepare() {
default_prepare
+ update_config_guess
chmod +x "$builddir"/install-sh
}
diff --git a/community/isync/APKBUILD b/community/isync/APKBUILD
index fc2cbefb2e8..3336844e149 100644
--- a/community/isync/APKBUILD
+++ b/community/isync/APKBUILD
@@ -21,6 +21,11 @@ source="$pkgname-$pkgver.tar.gz::https://downloads.sourceforge.net/sourceforge/i
# 1.4.1-r0:
# - CVE-2021-20247
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
build() {
./configure \
--build=$CBUILD \
diff --git a/community/libaacs/APKBUILD b/community/libaacs/APKBUILD
index 4590bb7f26b..704ab3c33f8 100644
--- a/community/libaacs/APKBUILD
+++ b/community/libaacs/APKBUILD
@@ -13,6 +13,11 @@ subpackages="$pkgname-dev"
source="https://download.videolan.org/pub/videolan/libaacs/$pkgver/libaacs-$pkgver.tar.bz2"
options="!check" # no tests provided
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
build() {
./configure \
--build=$CBUILD \
diff --git a/community/libdvdcss/APKBUILD b/community/libdvdcss/APKBUILD
index 1a8f7db6f8b..46d0acf0df0 100644
--- a/community/libdvdcss/APKBUILD
+++ b/community/libdvdcss/APKBUILD
@@ -14,6 +14,7 @@ source="https://download.videolan.org/pub/libdvdcss/$pkgver/libdvdcss-$pkgver.ta
prepare() {
default_prepare
+ update_config_guess
}
build() {
diff --git a/community/libfilezilla/APKBUILD b/community/libfilezilla/APKBUILD
index 54a37f55e83..4d7239f975c 100644
--- a/community/libfilezilla/APKBUILD
+++ b/community/libfilezilla/APKBUILD
@@ -12,6 +12,11 @@ checkdepends="cppunit-dev"
subpackages="$pkgname-dev $pkgname-lang"
source="https://download.filezilla-project.org/libfilezilla/libfilezilla-$pkgver.tar.xz"
+prepare() {
+ default_prepare
+ update_config_guess
+}
+
build() {
CFLAGS="$CFLAGS -flto=auto" \
CXXFLAGS="$CXXFLAGS -flto=auto" \
diff --git a/community/libfm-extra/APKBUILD b/community/libfm-extra/APKBUILD
index 3f173ecc091..e1ecc00d464 100644
--- a/community/libfm-extra/APKBUILD
+++ b/community/libfm-extra/APKBUILD
@@ -17,6 +17,11 @@ subpackages="$pkgname-dev"
source="https://downloads.sourceforge.net/pcmanfm/libfm-$pkgver.tar.xz"
builddir="$srcdir"/libfm-$pkgver
+prepare() {
+ default_prepare
+ update_config_guess
+}
+
build() {
./configure \
--prefix=/usr \
diff --git a/community/libfm/APKBUILD b/community/libfm/APKBUILD
index cc62cfc4c98..abf16467fdf 100644
--- a/community/libfm/APKBUILD
+++ b/community/libfm/APKBUILD
@@ -21,6 +21,11 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="
https://downloads.sourceforge.net/pcmanfm/libfm-$pkgver.tar.xz
"
+prepare() {
+ default_prepare
+ update_config_guess
+}
+
build() {
./configure \
--prefix=/usr \
diff --git a/community/libimobiledevice/APKBUILD b/community/libimobiledevice/APKBUILD
index 5dbdfa438f8..bb3f9d6c2b1 100644
--- a/community/libimobiledevice/APKBUILD
+++ b/community/libimobiledevice/APKBUILD
@@ -12,6 +12,10 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-progs $pkgname-python"
source="https://github.com/libimobiledevice/libimobiledevice/releases/download/$pkgver/libimobiledevice-$pkgver.tar.bz2
libplist-2.3.0.patch
"
+prepare() {
+ default_prepare
+ update_config_guess
+}
build() {
export CFLAGS="$CFLAGS -Wno-error=int-conversion"
diff --git a/community/libmatemixer/APKBUILD b/community/libmatemixer/APKBUILD
index ae765411671..0d3363c0030 100644
--- a/community/libmatemixer/APKBUILD
+++ b/community/libmatemixer/APKBUILD
@@ -11,6 +11,11 @@ makedepends="intltool glib-dev alsa-lib-dev pulseaudio-dev"
subpackages="$pkgname-doc $pkgname-dev $pkgname-lang"
source="https://pub.mate-desktop.org/releases/${pkgver%.*}/libmatemixer-$pkgver.tar.xz"
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
build() {
./configure \
--build=$CBUILD \
diff --git a/community/libqxp/APKBUILD b/community/libqxp/APKBUILD
index ba518a7b811..20224d078cc 100644
--- a/community/libqxp/APKBUILD
+++ b/community/libqxp/APKBUILD
@@ -10,6 +10,11 @@ makedepends="librevenge-dev icu-dev doxygen"
subpackages="$pkgname-dev $pkgname-doc"
source="https://dev-www.libreoffice.org/src/libqxp/libqxp-$pkgver.tar.xz"
+prepare() {
+ default_prepare
+ update_config_guess
+}
+
build() {
./configure --prefix=/usr \
--sysconfdir=/etc \
diff --git a/community/libthreadar/APKBUILD b/community/libthreadar/APKBUILD
index d6caa6c5fb5..301c737a2c6 100644
--- a/community/libthreadar/APKBUILD
+++ b/community/libthreadar/APKBUILD
@@ -9,6 +9,11 @@ license="LGPL-3.0-or-later"
subpackages="$pkgname-dev"
source="https://downloads.sourceforge.net/libthreadar/libthreadar-$pkgver.tar.gz"
+prepare() {
+ default_prepare
+ update_config_guess
+}
+
build() {
./configure --prefix=/usr
make
diff --git a/community/libu2f-server/APKBUILD b/community/libu2f-server/APKBUILD
index 96da6f1e8a7..06ca04a968f 100644
--- a/community/libu2f-server/APKBUILD
+++ b/community/libu2f-server/APKBUILD
@@ -13,6 +13,11 @@ source="https://developers.yubico.com/libu2f-server/Releases/libu2f-server-$pkgv
json-c-0.14.patch
"
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
build() {
./configure \
--build=$CBUILD \
diff --git a/community/libunibreak/APKBUILD b/community/libunibreak/APKBUILD
index 7d5a62b633f..ccce71263cc 100644
--- a/community/libunibreak/APKBUILD
+++ b/community/libunibreak/APKBUILD
@@ -10,6 +10,11 @@ subpackages="$pkgname-dev"
source="https://github.com/adah1972/libunibreak/releases/download/libunibreak_${pkgver//./_}/libunibreak-$pkgver.tar.gz"
options="!check" # no tests
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
build() {
CFLAGS="$CFLAGS -O2 -flto=auto" \
./configure \
diff --git a/community/mbuffer/APKBUILD b/community/mbuffer/APKBUILD
index 15a6a70d58a..137c9085af8 100644
--- a/community/mbuffer/APKBUILD
+++ b/community/mbuffer/APKBUILD
@@ -12,6 +12,11 @@ subpackages="$pkgname-doc"
source="https://www.maier-komor.de/software/mbuffer/mbuffer-$pkgver.tgz
fix-shell.patch"
+prepare() {
+ default_prepare
+ update_config_guess
+}
+
build() {
./configure \
--prefix=/usr \
diff --git a/community/monitoring-plugins/APKBUILD b/community/monitoring-plugins/APKBUILD
index f589196d830..f9d8cc544e6 100644
--- a/community/monitoring-plugins/APKBUILD
+++ b/community/monitoring-plugins/APKBUILD
@@ -24,6 +24,11 @@ checkdepends="cmd:ksh"
subpackages="$pkgname-lang $pkgname-doc"
source="https://www.monitoring-plugins.org/download/monitoring-plugins-$pkgver.tar.gz"
+prepare() {
+ default_prepare
+ update_config_guess
+}
+
build() {
./configure \
--prefix=/usr \
diff --git a/community/pam-u2f/APKBUILD b/community/pam-u2f/APKBUILD
index d42fab20e2e..75ba46524b2 100644
--- a/community/pam-u2f/APKBUILD
+++ b/community/pam-u2f/APKBUILD
@@ -17,6 +17,11 @@ builddir="$srcdir/pam_u2f-$pkgver"
# 1.1.1-r0:
# - CVE-2021-31924
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
build() {
./configure \
--build=$CBUILD \
diff --git a/community/pilot-link/APKBUILD b/community/pilot-link/APKBUILD
index 4f7041aea4e..96218f24e3c 100644
--- a/community/pilot-link/APKBUILD
+++ b/community/pilot-link/APKBUILD
@@ -40,6 +40,8 @@ prepare() {
cp "$srcdir/config.guess" "$builddir/"
cp "$srcdir/config.sub" "$builddir/"
default_prepare
+ update_config_sub
+ update_config_guess
}
build() {
diff --git a/community/telepathy-mission-control/APKBUILD b/community/telepathy-mission-control/APKBUILD
index 3dde8beb1d7..71356665e72 100644
--- a/community/telepathy-mission-control/APKBUILD
+++ b/community/telepathy-mission-control/APKBUILD
@@ -24,6 +24,11 @@ source="https://telepathy.freedesktop.org/releases/telepathy-mission-control/tel
provides="dbus:org.freedesktop.Telepathy.AccountManager"
provider_priority=10
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
build() {
./configure \
--build=$CBUILD \
diff --git a/community/tpm2-tss-engine/APKBUILD b/community/tpm2-tss-engine/APKBUILD
index bd36641d5e0..ab88f6e005c 100644
--- a/community/tpm2-tss-engine/APKBUILD
+++ b/community/tpm2-tss-engine/APKBUILD
@@ -16,6 +16,11 @@ subpackages="
source="https://github.com/tpm2-software/tpm2-tss-engine/releases/download/$pkgver/tpm2-tss-engine-$pkgver.tar.gz"
options="!check" # no tests
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
build() {
./configure \
--build=$CBUILD \
diff --git a/community/tpm2-tss/APKBUILD b/community/tpm2-tss/APKBUILD
index d3ca4fa1526..8efe6c7ea28 100644
--- a/community/tpm2-tss/APKBUILD
+++ b/community/tpm2-tss/APKBUILD
@@ -50,6 +50,11 @@ s390x)
;;
esac
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
build() {
./configure \
--build=$CBUILD \
diff --git a/community/udftools/APKBUILD b/community/udftools/APKBUILD
index 3d05d1e62e2..9a044ec92a6 100644
--- a/community/udftools/APKBUILD
+++ b/community/udftools/APKBUILD
@@ -14,6 +14,7 @@ options="!check" # No tests
prepare() {
default_prepare
+ update_config_guess
./autogen.sh
}
diff --git a/community/unrtf/APKBUILD b/community/unrtf/APKBUILD
index 43d55498e15..3c87eb1f0e2 100644
--- a/community/unrtf/APKBUILD
+++ b/community/unrtf/APKBUILD
@@ -10,6 +10,11 @@ license="GPL-3.0-or-later"
subpackages="$pkgname-doc"
source="https://ftp.gnu.org/gnu/unrtf/unrtf-$pkgver.tar.gz"
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
build() {
./configure \
--target="$CTARGET" \
diff --git a/community/vorbis-tools/APKBUILD b/community/vorbis-tools/APKBUILD
index 4b9189193c3..cf181e60e9a 100644
--- a/community/vorbis-tools/APKBUILD
+++ b/community/vorbis-tools/APKBUILD
@@ -16,6 +16,12 @@ source="https://downloads.xiph.org/releases/vorbis/vorbis-tools-$pkgver.tar.gz
# 9.54-r1:
# - CVE-2023-43361
+prepare() {
+ default_prepare
+ update_config_sub
+ update_config_guess
+}
+
build() {
./configure \
--prefix=/usr \
diff --git a/community/wavemon/APKBUILD b/community/wavemon/APKBUILD
index 4ff8ea8fe9a..5e2899aab2d 100644
--- a/community/wavemon/APKBUILD
+++ b/community/wavemon/APKBUILD
@@ -13,6 +13,11 @@ makedepends="ncurses-dev libcap-dev libnl3-dev"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/uoaerg/wavemon/archive/v$pkgver.tar.gz"
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
build() {
./configure \
--build=$CBUILD \
diff --git a/community/wpan-tools/APKBUILD b/community/wpan-tools/APKBUILD
index d747d36971f..7b0687e778b 100644
--- a/community/wpan-tools/APKBUILD
+++ b/community/wpan-tools/APKBUILD
@@ -13,6 +13,11 @@ options="!check" # upstream doesn't have a test suite currently
source="https://github.com/linux-wpan/wpan-tools/releases/download/wpan-tools-$pkgver/wpan-tools-$pkgver.tar.xz
"
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
build() {
./configure \
--build=$CBUILD \