aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCeleste <20312-Celeste@users.gitlab.alpinelinux.org>2024-04-25 04:21:12 +0000
committerCeleste <20312-Celeste@users.gitlab.alpinelinux.org>2024-04-25 05:22:20 +0000
commite0b134420c23903193419a3250744649f2997904 (patch)
tree6a4a1fccb619435b5f58dd6ff0ff21914087dafe
parent3bc6c9ef61d000b76193782e32b043aed6b6eb01 (diff)
community/llhttp: fix volatile patchHEADmaster
by importing it into aports
-rw-r--r--community/llhttp/APKBUILD2
-rw-r--r--community/llhttp/llhttp-sed.patch24
2 files changed, 25 insertions, 1 deletions
diff --git a/community/llhttp/APKBUILD b/community/llhttp/APKBUILD
index 05af8d55308..438fbbd9181 100644
--- a/community/llhttp/APKBUILD
+++ b/community/llhttp/APKBUILD
@@ -10,7 +10,7 @@ arch="all"
makedepends="cmake clang npm"
subpackages="$pkgname-dev $pkgname-doc"
source="https://github.com/nodejs/llhttp/archive/v$pkgver/llhttp-$pkgver.tar.gz
- $pkgname-sed.patch::https://github.com/nodejs/llhttp/commit/553ae7d1bda0b97a43af6b57ea2fd7ce04b6630d.patch
+ $pkgname-sed.patch
"
prepare() {
diff --git a/community/llhttp/llhttp-sed.patch b/community/llhttp/llhttp-sed.patch
new file mode 100644
index 00000000000..1c4fc5b9755
--- /dev/null
+++ b/community/llhttp/llhttp-sed.patch
@@ -0,0 +1,24 @@
+From 553ae7d1bda0b97a43af6b57ea2fd7ce04b6630d Mon Sep 17 00:00:00 2001
+From: "Benjamin A. Beasley" <code@musicinmybrain.net>
+Date: Tue, 27 Jun 2023 18:27:17 -0400
+Subject: [PATCH] Do not assume a particular sed implementation
+
+Make the release target in the Makefile more portable.
+---
+ Makefile | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 5b941b3..d9c6d35 100644
+--- a/Makefile
++++ b/Makefile
+@@ -52,8 +52,7 @@ release: clean generate
+ cp -rf src/native/*.c release/src/
+ cp -rf src/llhttp.gyp release/
+ cp -rf src/common.gypi release/
+- cp -rf CMakeLists.txt release/
+- sed -i '' s/_RELEASE_/$(RELEASE)/ release/CMakeLists.txt
++ sed s/_RELEASE_/$(RELEASE)/ CMakeLists.txt > release/CMakeLists.txt
+ cp -rf libllhttp.pc.in release/
+ cp -rf README.md release/
+ cp -rf LICENSE-MIT release/