aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCeleste <20312-Celeste@users.gitlab.alpinelinux.org>2024-04-18 13:24:51 +0000
committeromni <omni+alpine@hack.org>2024-04-18 23:39:50 +0000
commita513f2707e22e8437b0bb33f141f355492645ba2 (patch)
treec90adc1e343f869b0c750440f38a9e4a83c18d94
parent31962a327294e889ccd653e10e55bf0c618921f2 (diff)
community/emacs: take over maintainershipHEADmaster
also, fix pkgdesc
-rw-r--r--community/emacs/APKBUILD29
1 files changed, 18 insertions, 11 deletions
diff --git a/community/emacs/APKBUILD b/community/emacs/APKBUILD
index 3941099b61f..a957398f530 100644
--- a/community/emacs/APKBUILD
+++ b/community/emacs/APKBUILD
@@ -1,11 +1,13 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Celeste <cielesti@protonmail.com>
pkgname=emacs
pkgver=29.3
-pkgrel=0
-pkgdesc="Extensible, customizable, self-documenting real-time display editor (common files)"
-arch="all"
+pkgrel=1
+_pkgdesc="Extensible, customizable, self-documenting real-time display editor"
+pkgdesc="$_pkgdesc (common files)"
url="https://www.gnu.org/software/emacs/emacs.html"
+arch="all"
license="GPL-3.0-or-later"
makedepends="
!libexecinfo-dev
@@ -201,6 +203,11 @@ package() {
find usr/lib -perm -g+s,g+x ! -type d -exec chmod g-s {} \;
}
+doc() {
+ default_doc
+ pkgdesc="$_pkgdesc (documentation)"
+}
+
_subpackage() {
cd "$builddir/$1"
make DESTDIR="$subpkgdir" install
@@ -232,7 +239,7 @@ _subpackage() {
}
nox() {
- pkgdesc="$pkgdesc - non-graphical"
+ pkgdesc="$_pkgdesc - non-graphical"
depends="
$pkgname=$pkgver-r$pkgrel
!emacs-gtk3
@@ -246,7 +253,7 @@ nox() {
}
x11() {
- pkgdesc="$pkgdesc - with X11"
+ pkgdesc="$_pkgdesc - with X11"
depends="
$pkgname=$pkgver-r$pkgrel
!emacs-gtk3
@@ -262,7 +269,7 @@ x11() {
}
x11_nativecomp() {
- pkgdesc="$pkgdesc - with X11 and native compilation"
+ pkgdesc="$_pkgdesc - with X11 and native compilation"
depends="
$pkgname=$pkgver-r$pkgrel
!emacs-gtk3
@@ -278,7 +285,7 @@ x11_nativecomp() {
}
gtk3() {
- pkgdesc="$pkgdesc - with GTK3"
+ pkgdesc="$_pkgdesc - with GTK3"
depends="
$pkgname=$pkgver-r$pkgrel
!emacs-gtk3-nativecomp
@@ -294,7 +301,7 @@ gtk3() {
}
gtk3_nativecomp() {
- pkgdesc="$pkgdesc - with GTK3 and native compilation"
+ pkgdesc="$_pkgdesc - with GTK3 and native compilation"
depends="
$pkgname=$pkgver-r$pkgrel
!emacs-gtk3
@@ -310,7 +317,7 @@ gtk3_nativecomp() {
}
pgtk() {
- pkgdesc="$pkgdesc - with pure GTK"
+ pkgdesc="$_pkgdesc - with pure GTK"
depends="
$pkgname=$pkgver-r$pkgrel
!emacs-gtk3
@@ -326,7 +333,7 @@ pgtk() {
}
pgtk_nativecomp() {
- pkgdesc="$pkgdesc - with pure GTK and native compilation"
+ pkgdesc="$_pkgdesc - with pure GTK and native compilation"
depends="
$pkgname=$pkgver-r$pkgrel
!emacs-gtk3