aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorptrcnull <git@ptrcnull.me>2024-03-28 11:11:35 +0100
committerptrcnull <git@ptrcnull.me>2024-03-28 11:11:35 +0100
commit40b52ebc5f1a1eff4f42987e6ddedb6d00d43726 (patch)
treeb31c77a614f43bbee90c784ea55891d9e6b86ac9
parent7ba86b0710af5e05f84ac4f869970cc8d57d2ea7 (diff)
community/py3-skia-pathops: fix tests with python 3.12HEADmaster
-rw-r--r--community/py3-skia-pathops/APKBUILD3
-rw-r--r--community/py3-skia-pathops/cpdef.patch28
2 files changed, 30 insertions, 1 deletions
diff --git a/community/py3-skia-pathops/APKBUILD b/community/py3-skia-pathops/APKBUILD
index 7268c29d469..566a83ed3fb 100644
--- a/community/py3-skia-pathops/APKBUILD
+++ b/community/py3-skia-pathops/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=py3-skia-pathops
pkgver=0.7.4
-pkgrel=1
+pkgrel=2
pkgdesc="Python bindings for the Skia library's Path Ops"
url="https://github.com/fonttools/skia-pathops"
arch="all !s390x" # doesn't support big endian
@@ -21,6 +21,7 @@ checkdepends="py3-pytest-xdist"
subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/s/skia-pathops/skia-pathops-$pkgver.zip
gn-ninja.patch
+ cpdef.patch
"
builddir="$srcdir/skia-pathops-$pkgver"
options="net"
diff --git a/community/py3-skia-pathops/cpdef.patch b/community/py3-skia-pathops/cpdef.patch
new file mode 100644
index 00000000000..bcd905407e7
--- /dev/null
+++ b/community/py3-skia-pathops/cpdef.patch
@@ -0,0 +1,28 @@
+src/python/pathops/_pathops.pyx:691:6: Variables cannot be declared with 'cpdef'. Use 'cdef' instead.
+
+diff --git a/src/python/pathops/_pathops.pxd b/src/python/pathops/_pathops.pxd
+index 0b01fa9..6e12db0 100644
+--- a/src/python/pathops/_pathops.pxd
++++ b/src/python/pathops/_pathops.pxd
+@@ -213,5 +213,5 @@ cdef uint8_t *POINTS_IN_VERB
+
+-cpdef dict VERB_METHODS
++cdef dict VERB_METHODS
+
+-cpdef dict PEN_METHODS
++cdef dict PEN_METHODS
+
+diff --git a/src/python/pathops/_pathops.pyx b/src/python/pathops/_pathops.pyx
+index 7f1517f..7a3d557 100644
+--- a/src/python/pathops/_pathops.pyx
++++ b/src/python/pathops/_pathops.pyx
+@@ -690,3 +690,3 @@ cdef uint8_t *POINTS_IN_VERB = [
+
+-cpdef dict VERB_METHODS = {
++cdef dict VERB_METHODS = {
+ kMove_Verb: "moveTo",
+@@ -699,3 +699,3 @@ cpdef dict VERB_METHODS = {
+
+-cpdef dict PEN_METHODS = {
++cdef dict PEN_METHODS = {
+ kMove_Verb: "moveTo",