aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarian Buschsieweke <marian.buschsieweke@posteo.net>2024-04-18 20:51:16 +0200
committeromni <omni+alpine@hack.org>2024-04-19 04:46:07 +0000
commit0d2b17a1fd92e8d371c54870aaa705946fe7658f (patch)
tree6779551d36f3d2e7b20c575051048953e1565228
parent80c55c1d34686bfd3bef2f8b7bbc8f48684ee382 (diff)
community/texmf-dist: fix -doc subpackagesHEADmaster
Before I naively used `default_doc` for `-doc` subpackages, but this only works if there is only a single `-doc` subpackages, as otherwise all `-doc` packages would be installed if `docs` and the root package is installed. This fixes the issue by hand-rolling the split function for the non-root `-doc` subpackage.
-rw-r--r--community/texmf-dist/APKBUILD14
1 files changed, 13 insertions, 1 deletions
diff --git a/community/texmf-dist/APKBUILD b/community/texmf-dist/APKBUILD
index 9735cc0881c..f482e23d8fe 100644
--- a/community/texmf-dist/APKBUILD
+++ b/community/texmf-dist/APKBUILD
@@ -83,7 +83,7 @@ builddir="$srcdir/texlive-$_release-texmf"
# in the db. The split function for the -doc subpackages will then only
# compress the man pages.
for collection in $_collections; do
- subpackages="$subpackages $pkgname-$collection:_subpkg $pkgname-$collection-doc"
+ subpackages="$subpackages $pkgname-$collection:_subpkg $pkgname-$collection-doc:_subpkgdoc:noarch"
done
_tlpdb="$srcdir/texlive-$pkgver.tlpdb"
@@ -340,6 +340,18 @@ _subpkg() {
_pack_collection "$collection" "$subpkgdir" "${subpkgdir%/}-doc"
}
+_subpkgdoc() {
+ # We cannot use default_doc, as this does not work for subpackges
+
+ install_if="docs ${subpkgname%-doc}=$pkgver-r$pkgrel"
+
+ # compress man pages, if the doc packages contains some
+ if [ -d "$subpkgdir"/usr/share/man ]; then
+ find "$subpkgdir"/usr/share/man -type f ! -name "*.gz" \
+ -exec gzip -9 {} \;
+ fi
+}
+
_most() {
pkgdesc="TeX Live texmf distribution including most packages"
# everything but texmf-dist-lang* and texmf-dist-fontsextra