aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2024-04-19 19:48:34 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2024-04-19 21:01:21 +0200
commit3c028259769def26fa51821abaaabe8e410a2371 (patch)
treea60600518c88d7bdcadb7b49ed60b9eb71fbbec2
parentbd50092b569a138e63d90ff27c5e819a2aa680ce (diff)
main/util-linux: support APORTS_BOOTSTRAPHEADmaster
build fewer subpackages and fewr deps while boostrapping aports
-rw-r--r--main/util-linux/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/main/util-linux/APKBUILD b/main/util-linux/APKBUILD
index aa29dc31dad..41b14ca20fa 100644
--- a/main/util-linux/APKBUILD
+++ b/main/util-linux/APKBUILD
@@ -50,7 +50,7 @@ subpackages="
uuidgen:_mv_bin
wipefs:_mv_bin
"
-if [ -z "$BOOTSTRAP" ]; then
+if [ -z "$BOOTSTRAP" ] && [ -z "$APORTS_BOOTSTRAP" ]; then
checkdepends="bash findutils xz procps coreutils"
makedepends_build="$makedepends_build asciidoctor"
makedepends_host="$makedepends_host
@@ -69,7 +69,7 @@ if [ -z "$BOOTSTRAP" ]; then
_bootstrap_config="--enable-runuser --with-python=3 --with-econf"
else
options="!check"
- _bootstrap_config="--without-python --without-econf --disable-asciidoc --disable-login"
+ _bootstrap_config="--disable-runuser --without-python --without-econf --disable-asciidoc --disable-login"
fi
subpackages="$subpackages $pkgname-doc $pkgname-misc"
makedepends="$makedepends_build $makedepends_host"
@@ -125,7 +125,8 @@ prepare() {
}
build() {
- if [ -z "$BOOTSTRAP" ]; then
+ set -x
+ if [ -z "$BOOTSTRAP" ] && [ -z "$APORTS_BOOTSTRAP" ]; then
# Linking utmps statically is strongly preferred by the utmps author
# and also much more space efficient - adds 4 kiB to each binary, that's
# 20 kiB in total for util-linux-*, versus 196 kiB (libskarnet.so).