aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRob Blanckaert <rob@basicer.com>2024-04-19 05:05:29 +0000
committerCeleste <20312-Celeste@users.gitlab.alpinelinux.org>2024-04-19 06:11:06 +0000
commitd7f0b8c32f8d207bda7eebf92074906e201332b8 (patch)
treeb48ca941a64f1ede8f97c690a410d8a4c33fca43
parent7c8028288544efdc878b93a818a582b3443319a6 (diff)
community/luau: upgrade to 0.621HEADmaster
-rw-r--r--community/luau/APKBUILD6
-rw-r--r--community/luau/weak-unwind.patch13
2 files changed, 2 insertions, 17 deletions
diff --git a/community/luau/APKBUILD b/community/luau/APKBUILD
index 95bf48838a6..9590d2d72bb 100644
--- a/community/luau/APKBUILD
+++ b/community/luau/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Rob Blanckaert <basicer@gmail.com>
# Maintainer: Rob Blanckaert <basicer@gmail.com>
pkgname=luau
-pkgver=0.612
+pkgver=0.621
pkgrel=0
pkgdesc="A fast, small, safe, gradually typed embeddable scripting language derived from Lua"
url="https://github.com/roblox/luau"
@@ -10,7 +10,6 @@ license="MIT"
makedepends="cmake linux-headers samurai"
source="
$pkgname-$pkgver.tar.gz::https://github.com/luau-lang/luau/archive/refs/tags/$pkgver.tar.gz
-weak-unwind.patch
"
build() {
@@ -36,6 +35,5 @@ package() {
}
sha512sums="
-442c1528e119e9ad8b58b76cafdca5b59240be04852851f3bb3566276e2ee8b13f65b0225b3db6ef3f8e459b3d3ff7f665a7684c7bef7d588dd9f7f493b13389 luau-0.612.tar.gz
-7589340a874cd99d26d5eced8015b52fa4e151c4801e60ddd98fd948486a25c21372120fa02abc610d5aa157eeb9dd008835f81da04be0be3f319841405129f8 weak-unwind.patch
+be96a6dc2e1092fe4fd4ad215978bbf4341ff6ddde08763b03467edebf8b7610fb580b8f7b09220846d64245ef27502316e1b35826c581e5eae7329c99d7a84f luau-0.621.tar.gz
"
diff --git a/community/luau/weak-unwind.patch b/community/luau/weak-unwind.patch
deleted file mode 100644
index d24c338c28b..00000000000
--- a/community/luau/weak-unwind.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- base/CodeGen/src/CodeBlockUnwind.cpp
-+++ luau-0.610/CodeGen/src/CodeBlockUnwind.cpp
-@@ -20,8 +20,8 @@
- #elif defined(__linux__) || defined(__APPLE__)
-
- // Defined in unwind.h which may not be easily discoverable on various platforms
--extern "C" void __register_frame(const void*);
--extern "C" void __deregister_frame(const void*);
-+extern "C" void __register_frame(const void*) __attribute__((weak));
-+extern "C" void __deregister_frame(const void*) __attribute__((weak));
-
- extern "C" void __unw_add_dynamic_fde() __attribute__((weak));
- #endif