aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2024-04-23 08:26:42 +0200
committerBart Ribbers <bribbers@disroot.org>2024-04-23 07:26:27 +0000
commitbb1af4aaf921fa86a2acebfa2e1a5d113bd3bd7e (patch)
tree4e0c391358605e2ba65c1fa379f98c0b3c7588bf
parent4fc05328fc0d8f3e14268b25d64577f76dd0bc98 (diff)
community/mbedtls2: move mbedtls replaces to the -utils subpackageHEADmaster
The main package doesn't actually conflict with mbedtls so allow installing them next to each other
-rw-r--r--community/mbedtls2/APKBUILD17
1 files changed, 7 insertions, 10 deletions
diff --git a/community/mbedtls2/APKBUILD b/community/mbedtls2/APKBUILD
index e3446c08f86..5d4719e1a0f 100644
--- a/community/mbedtls2/APKBUILD
+++ b/community/mbedtls2/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mbedtls2
pkgver=2.28.8 # long-time support branch
-pkgrel=0
+pkgrel=1
pkgdesc="Light-weight cryptographic and SSL/TLS library"
url="https://www.trustedfirmware.org/projects/mbed-tls/"
arch="all"
@@ -13,9 +13,6 @@ subpackages="$pkgname-static $pkgname-dev $pkgname-utils"
source="mbedtls-$pkgver.tar.gz::https://github.com/ARMmbed/mbedtls/archive/v$pkgver.tar.gz"
builddir="$srcdir/mbedtls-$pkgver"
-replaces="mbedtls"
-provides="mbedtls=$pkgver-r$pkgrel"
-
# Track security issues
# https://tls.mbed.org/security
@@ -70,9 +67,8 @@ build() {
}
check() {
- cd build
# tests break in parallel
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest -j1
+ ctest -j1 --test-dir build --output-on-failure
}
package() {
@@ -81,16 +77,17 @@ package() {
utils() {
pkgdesc="Utilities for mbedtls (including gen_key / cert_write)"
+ replaces="mbedtls-utils"
+ provides="mbedtls-utils=$pkgver-r$pkgrel"
+
- mkdir -p "$subpkgdir"/usr
- mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
+ amove usr/bin
}
static() {
pkgdesc="Static files for mbedtls"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/*.a "$subpkgdir"/usr/lib/
+ amove usr/lib/*.a
chmod -x "$subpkgdir"/usr/lib/*.a
}