aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoromni <omni+alpine@hack.org>2024-04-14 01:18:01 +0000
committerJ0WI <1715-J0WI@users.gitlab.alpinelinux.org>2024-04-20 14:06:46 +0000
commit943dfe7997dd56d6acf1fd731c8d2630bd58efcf (patch)
tree35bf8d4a39791fdcb38e2a688828094b37dbbc9c
parent495a34274f27ba6d9e148e5fd951c04c17232853 (diff)
main/py3-elementpath: upgrade to 4.4.0HEADmaster
- update test deselection
-rw-r--r--main/py3-elementpath/APKBUILD21
1 files changed, 9 insertions, 12 deletions
diff --git a/main/py3-elementpath/APKBUILD b/main/py3-elementpath/APKBUILD
index 09750158a9f..bdbde113cb4 100644
--- a/main/py3-elementpath/APKBUILD
+++ b/main/py3-elementpath/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Aiden Grossman <agrossman154@yahoo.com>
# Maintainer: Aiden Grossman <agrossman154@yahoo.com>
pkgname=py3-elementpath
-pkgver=4.1.5
-pkgrel=2
+pkgver=4.4.0
+pkgrel=0
pkgdesc="XPath 1.0/2.0 parsers and selectors for ElementTree and lxml"
url="https://github.com/sissaschool/elementpath"
arch="noarch"
@@ -22,19 +22,16 @@ build() {
check() {
python3 -m venv --clear --without-pip --system-site-packages .testenv
.testenv/bin/python3 -m installer .dist/*.whl
- # first four disabled tests fails on locale differences
- # Rest of the tests need more investigation, started with upgrade to 4.1.0
+ # first: AssertionError: ElementPathError not raised
+ # rest: AssertionError: First sequence is not a list: -1
.testenv/bin/python3 -m pytest \
- --ignore=tests/test_sequence_types.py \
- --deselect tests/test_xpath2_functions.py::XPath2FunctionsTest::test_compare_function \
- --deselect tests/test_xpath30.py::XPath30FunctionsTest::test_compare_function \
- --deselect tests/test_xpath31.py::XPath31FunctionsTest::test_compare_function \
--deselect tests/test_collations.py::CollationsTest::test_context_activation \
+ --deselect tests/test_xpath2_functions.py::XPath2FunctionsTest::test_compare_function \
--deselect tests/test_xpath2_functions.py::LxmlXPath2FunctionsTest::test_compare_function \
+ --deselect tests/test_xpath30.py::XPath30FunctionsTest::test_compare_function \
--deselect tests/test_xpath30.py::LxmlXPath30FunctionsTest::test_compare_function \
- --deselect tests/test_xpath31.py::LxmlXPath31FunctionsTest::test_compare_function \
- --deselect tests/test_validators.py::ValidatorsTest::test_validate_analyzed_string \
- --deselect tests/test_validators.py::ValidatorsTest::test_validate_json_to_xml
+ --deselect tests/test_xpath31.py::XPath31FunctionsTest::test_compare_function \
+ --deselect tests/test_xpath31.py::LxmlXPath31FunctionsTest::test_compare_function
}
package() {
@@ -43,5 +40,5 @@ package() {
}
sha512sums="
-29989210238aacdf111cba49d09488254a6bd479b381e57699c8d1eca8ec21badf666744402aae891210142ce56cfce66b55bf372e5de8b7b48a45bed46b0cf3 py3-elementpath-4.1.5.tar.gz
+8171cb004dba68d84dd26a9ac5e8feeb9cc87eb518cc232b3128dadd7ad92840903fe2d02eb4428e4e4df7590bf6c68bdae180ad678bccb969686875b0a84ae1 py3-elementpath-4.4.0.tar.gz
"