aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZach DeCook <zachdecook@librem.one>2024-04-22 22:01:48 -0400
committeromni <omni+alpine@hack.org>2024-04-23 07:59:26 +0000
commit2e589057df3c6990b5f1232dd53500602ce2aa81 (patch)
tree65d7b538637df23981d63941e4bac1432c09e774
parent9a3f3cccf130e5e6802767cdf682fd7b9f815847 (diff)
testing/hyprland: upgrade to 0.39.1HEADmaster
-rw-r--r--testing/hyprland/APKBUILD27
-rw-r--r--testing/hyprland/bump-soversion.patch.wlroots13
2 files changed, 12 insertions, 28 deletions
diff --git a/testing/hyprland/APKBUILD b/testing/hyprland/APKBUILD
index 6c47294ded3..c6645578734 100644
--- a/testing/hyprland/APKBUILD
+++ b/testing/hyprland/APKBUILD
@@ -1,20 +1,19 @@
# Contributor: Zach DeCook <zachdecook@librem.one>
# Maintainer: Zach DeCook <zachdecook@librem.one>
pkgname=hyprland
-pkgver=0.38.1
+pkgver=0.39.1
pkgrel=0
-_commit="360ede79d124ffdeebbe8401f1ac4bc0dbec2c91"
-_wlroots_commit="50eae512d9cecbf0b3b1898bb1f0b40fa05fe19b"
-_wlroots_date=20240302
+_commit="fe7b748eb668136dd0558b7c8279bfcd7ab4d759"
+_wlroots_commit="611a4f24cd2384378f6e500253983107c6656c64"
+_wlroots_date=20240414
pkgdesc="Highly customizable dynamic tiling Wayland compositor that doesn't sacrifice on its looks."
url="https://hyprland.org"
arch="all"
license="BSD-3-Clause"
source="
https://github.com/hyprwm/Hyprland/archive/v$pkgver/Hyprland-v$pkgver.tar.gz
- https://gitlab.freedesktop.org/wlroots/wlroots/-/archive/$_wlroots_commit/wlroots-$_wlroots_commit.tar.gz
+ https://github.com/hyprwm/wlroots-hyprland/archive/$_wlroots_commit/wlroots-hyprland-$_wlroots_commit.tar.gz
use-system-installed-udis86.patch
- bump-soversion.patch.wlroots
"
builddir="$srcdir/Hyprland-$pkgver"
makedepends="
@@ -24,7 +23,7 @@ makedepends="
eudev-dev
glslang-dev
hwdata-dev
- hyprcursor-dev
+ hyprcursor-dev>=0.1.7
hyprland-protocols
hyprlang
jq
@@ -57,13 +56,12 @@ subpackages="$pkgname-doc $pkgname-dev $pkgname-wallpapers::noarch"
prepare() {
default_prepare
# Use downloaded wlroots (instead of git submodule)
- rmdir subprojects/wlroots
- mv "$srcdir/wlroots-$_wlroots_commit" "$builddir"/subprojects/wlroots
+ rmdir subprojects/wlroots-hyprland
+ mv "$srcdir/wlroots-hyprland-$_wlroots_commit" "$builddir"/subprojects/wlroots-hyprland
# Change the soversion (appending current hyprland version)
- cd "$builddir"/subprojects/wlroots
- git apply "$srcdir"/bump-soversion.patch.wlroots
+ cd "$builddir"/subprojects/wlroots-hyprland
# Make the version number valid
- sed -i "s/-dev/_git$_wlroots_date/" "$builddir"/subprojects/wlroots/meson.build
+ sed -i "s/-dev/_git$_wlroots_date/" "$builddir"/subprojects/wlroots-hyprland/meson.build
# Set some variables in version.h.in
sed -i "s/@HASH@/$_commit/" "$builddir"/src/version.h.in
sed -i "s/@BRANCH@/build-alpine/" "$builddir"/src/version.h.in
@@ -92,8 +90,7 @@ wallpapers() {
}
sha512sums="
-a84c7c7e2b634032eb79d7c73efefaa99fb506f36eed7cea9dac09bfe53b46accef9145ae062b4a9fd3f8121d3abb52fe2465d176c950d498115da8ae111127e Hyprland-v0.38.1.tar.gz
-ce09d175f12cf25021caf18c0eac56aad97d238b3e2c4bfcc071d12d1bb8a44ee5c3aceab72ce3002928ca3c2c833bb5992b4820b44e0d0985c343ae903d056e wlroots-50eae512d9cecbf0b3b1898bb1f0b40fa05fe19b.tar.gz
+173dc2baea68e301fad13b1634779f859263abdba7ab60233791c6c8c8ed2def24afdfb51d3db1820646b391530f1f6aeca82d8cf6de1ef178810c11fbdef37b Hyprland-v0.39.1.tar.gz
+157c94643bc630b1c97f05f620c2adb21f744cac16ed8c53ab377820ce8af2ec6b826197a41b6814a838b6e032b92a790f4214210831f8e91a6aff0346f54027 wlroots-hyprland-611a4f24cd2384378f6e500253983107c6656c64.tar.gz
d2f7b35552fa0a3e992b9050f7066d983b3b7c193a888018b2e0d6fa9e17fc3deff922fa3989d0bb79e8bd82df2bc16ff0c27a82759ad0ce2e72789506eb07db use-system-installed-udis86.patch
-ca673fbb7a7c91a4902e6357ad90854070e9c7d16dc298787a819aac9d6f4832d4657029427b144709e56bead604d4df162d81892d23d6a2b94634e3bd2380ab bump-soversion.patch.wlroots
"
diff --git a/testing/hyprland/bump-soversion.patch.wlroots b/testing/hyprland/bump-soversion.patch.wlroots
deleted file mode 100644
index fad516896e8..00000000000
--- a/testing/hyprland/bump-soversion.patch.wlroots
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/meson.build b/meson.build
-index 95803a22..fd1bb7be 100644
---- a/meson.build
-+++ b/meson.build
-@@ -15,7 +15,7 @@ version = meson.project_version().split('-')[0]
- version_major = version.split('.')[0]
- version_minor = version.split('.')[1]
- assert(version_major == '0')
--soversion = version_minor.to_int() - 5
-+soversion = 13037
-
- little_endian = target_machine.endian() == 'little'
- big_endian = target_machine.endian() == 'big'