aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoromni <omni+alpine@hack.org>2024-04-24 11:48:10 +0000
committerPatrycja Rosa <alpine@ptrcnull.me>2024-04-24 13:20:00 +0000
commit160237621679c4d9d7f904fffe7aeb7491513251 (patch)
tree14aed26cf442673baed405e6977e7228a8fe7415
parent15353eee6c7224c25aff910e9daba303e5aafdea (diff)
community/tracker: upgrade to 3.7.1HEADmaster
apply upstream patch for sqlite 3.45.3
-rw-r--r--community/tracker/APKBUILD17
-rw-r--r--community/tracker/Fix-incompatibility-introduced-by-SQLite-3.45.3.patch44
2 files changed, 51 insertions, 10 deletions
diff --git a/community/tracker/APKBUILD b/community/tracker/APKBUILD
index fc3e30eeed0..e61c9684a6a 100644
--- a/community/tracker/APKBUILD
+++ b/community/tracker/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=tracker
-pkgver=3.6.0
-pkgrel=3
+pkgver=3.7.1
+pkgrel=0
pkgdesc="Personal search tool and storage system"
url="https://tracker.gnome.org/"
arch="all"
@@ -37,13 +37,9 @@ subpackages="
lib$pkgname:libs
$pkgname-bash-completion
$pkgname-testutils:_testutils"
-source="https://download.gnome.org/sources/tracker/${pkgver%.*}/tracker-$pkgver.tar.xz"
-
-# x86: still sigabrts
-# armhf: hang for a really long time
-case "$CARCH" in
-armhf|x86) options="$options !check" ;;
-esac
+source="https://download.gnome.org/sources/tracker/${pkgver%.*}/tracker-$pkgver.tar.xz
+ Fix-incompatibility-introduced-by-SQLite-3.45.3.patch
+ "
build() {
abuild-meson \
@@ -73,5 +69,6 @@ _testutils() {
}
sha512sums="
-d3b7d4c1fd1cdcccc0d78c05f43b85f5cdab584e378cb56a2b568293ff95c887650d41c3c7f65de8864a0b6f80ae26410f4a443f045a80e30bacdf7ef9499697 tracker-3.6.0.tar.xz
+fd00868d7f3dd983fe31f4d478ab0f0bd2ecc1d1196e8ba589dc757a84086c46c1a1d0c60de7d32d1c60396bb7b2faafa1e9d07240d4ce84160c6332f8daf10a tracker-3.7.1.tar.xz
+8ec042a012a9ba5d818214672266fe548c2287f850ac9791806c796f4cfdfd9d1f878701b2e8d621848457c1807b2b67bba9de4f356b4a836a1c3614e15e8370 Fix-incompatibility-introduced-by-SQLite-3.45.3.patch
"
diff --git a/community/tracker/Fix-incompatibility-introduced-by-SQLite-3.45.3.patch b/community/tracker/Fix-incompatibility-introduced-by-SQLite-3.45.3.patch
new file mode 100644
index 00000000000..72e37c83068
--- /dev/null
+++ b/community/tracker/Fix-incompatibility-introduced-by-SQLite-3.45.3.patch
@@ -0,0 +1,44 @@
+From 0c576af6df5af2f1b8df9841fbb566fa52a4e382 Mon Sep 17 00:00:00 2001
+From: Carlos Garnacho <carlosg@gnome.org>
+Date: Thu, 18 Apr 2024 14:18:08 +0200
+Subject: [PATCH] core: Fix incompatibility introduced by SQLite 3.45.3
+
+For the umpteenth time, SQLite introduced behavioral changes that
+we need to adapt to. This time, version 3.45.3 "fixed" at
+https://github.com/sqlite/sqlite/commit/74851f66811854c772a9b2d0a13f1e9e82b69c25
+their SQLITE_ALLOW_ROWID_IN_VIEW build-time option which controls the
+behavior of views having an implicit ROWID column vs not.
+
+This broke our view used to proxy data to the content-less FTS5
+table, since the SELECT query it translates to used a naked reference to
+ROWID that is now deemed "ambiguous" by SQLite engine, this results
+in the following errors:
+
+Tracker:ERROR:../tests/core/tracker-ontology-test.c:231:test_query: assertion failed (error == NULL): ambiguous column name: ROWID (tracker-db-interface-error-quark, 0)
+
+We are actually referencing data inside the SELECT query, so fix this
+ambiguity by stating clearly the table/column that we are referring to
+within the SELECT query clause. This is backwards compatible with older
+versions of SQLite.
+
+Closes: https://gitlab.gnome.org/GNOME/tracker/-/issues/435
+---
+ src/libtracker-sparql/core/tracker-fts.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/libtracker-sparql/core/tracker-fts.c b/src/libtracker-sparql/core/tracker-fts.c
+index 1171dc11a8..99600820bd 100644
+--- a/src/libtracker-sparql/core/tracker-fts.c
++++ b/src/libtracker-sparql/core/tracker-fts.c
+@@ -112,7 +112,7 @@ tracker_fts_create_table (sqlite3 *db,
+
+ g_string_append_printf (from, "WHERE COALESCE (%s NULL) IS NOT NULL ",
+ column_names->str);
+- g_string_append (from, "GROUP BY ROWID");
++ g_string_append (from, "GROUP BY \"rdfs:Resource\".ID");
+ g_string_append (str, from->str);
+ g_string_free (from, TRUE);
+
+--
+GitLab
+