aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCeleste <20312-Celeste@users.gitlab.alpinelinux.org>2024-04-24 03:21:14 +0000
committerCeleste <20312-Celeste@users.gitlab.alpinelinux.org>2024-04-24 03:38:52 +0000
commit1800f4f0060aa17fbe10686a0a66161b216c5bf9 (patch)
tree39fd4def0a6c820ccb47a2f52733df27ef58cac3
parentb74cb5db151f0f3d7b9e2337cf5cacf74c194272 (diff)
main/numactl: disable test/distance on riscv64HEADmaster
This test was previously disabled on x86, and s390x before that, see 775474dc51474e8904b6d003b5c9919959eb8425
-rw-r--r--main/numactl/APKBUILD12
1 files changed, 11 insertions, 1 deletions
diff --git a/main/numactl/APKBUILD b/main/numactl/APKBUILD
index 519dff89e2b..983256f4bf9 100644
--- a/main/numactl/APKBUILD
+++ b/main/numactl/APKBUILD
@@ -27,7 +27,17 @@ build() {
}
check() {
- make check VERBOSE=1 TESTS='test/distance test/nodemap test/tbitmap'
+ local tests="test/nodemap test/tbitmap"
+
+ # riscv64 builder: "FAIL test/distance (exit status: 139)"
+ case "$CARCH" in
+ riscv64) ;;
+ *)
+ tests="test/distance $tests"
+ ;;
+ esac
+
+ make check VERBOSE=1 TESTS="$tests"
}
package() {