aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCeleste <20312-Celeste@users.gitlab.alpinelinux.org>2024-04-24 05:07:39 +0000
committerCeleste <20312-Celeste@users.gitlab.alpinelinux.org>2024-04-24 05:07:39 +0000
commit5bcb05d4606a93793123e89d1816e43171fd608c (patch)
tree979da3e432031f92c503198d51acaf404d51b801
parente7999716d2bb60b6a1400ab851f6caa7fc4f39c4 (diff)
community/perl-webservice-musicbrainz: fix Artist.t testHEADmaster
-rw-r--r--community/perl-webservice-musicbrainz/APKBUILD5
-rw-r--r--community/perl-webservice-musicbrainz/artist-test.patch24
2 files changed, 28 insertions, 1 deletions
diff --git a/community/perl-webservice-musicbrainz/APKBUILD b/community/perl-webservice-musicbrainz/APKBUILD
index f993d8562b6..42b728ddb56 100644
--- a/community/perl-webservice-musicbrainz/APKBUILD
+++ b/community/perl-webservice-musicbrainz/APKBUILD
@@ -13,7 +13,9 @@ license="GPL-1.0-or-later OR Artistic-1.0-Perl"
depends="perl perl-io-socket-ssl"
makedepends="perl-dev perl-mojolicious perl-module-build"
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/B/BF/BFAIST/WebService-MusicBrainz-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/B/BF/BFAIST/WebService-MusicBrainz-$pkgver.tar.gz
+ artist-test.patch
+ "
builddir="$srcdir/$_pkgreal-$pkgver"
build() {
@@ -33,4 +35,5 @@ package() {
sha512sums="
b9cb8a4873c0a32575afbeaa57068a2b533dd3213d747b3577a378da2844b325e9b50477ccb3c5461b34a319078a59cf802be93f1cc094cb6f12c13c92c9611a WebService-MusicBrainz-1.0.6.tar.gz
+1e53ab62260762973a6234bcc6de8d152829dd6cb6325e03bef8054bd238fdc00358aee8bd0a0862a7523bf095458552091e343efc5eecb877f6883df4663a1c artist-test.patch
"
diff --git a/community/perl-webservice-musicbrainz/artist-test.patch b/community/perl-webservice-musicbrainz/artist-test.patch
new file mode 100644
index 00000000000..f82afc006a4
--- /dev/null
+++ b/community/perl-webservice-musicbrainz/artist-test.patch
@@ -0,0 +1,24 @@
+Patch-Source: https://github.com/bfaist/webservice-musicbrainz/pull/15.patch
+--
+From d858eff52da7e6409eef088eb41207f87ec0c313 Mon Sep 17 00:00:00 2001
+From: gregor herrmann <gregoa@debian.org>
+Date: Tue, 27 Feb 2024 18:08:56 +0100
+Subject: [PATCH] Fix t/Artist.t: Van Halen is not unique any more.
+
+---
+ t/Artist.t | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/t/Artist.t b/t/Artist.t
+index c33b393..73d92a0 100644
+--- a/t/Artist.t
++++ b/t/Artist.t
+@@ -55,7 +55,7 @@ sleep(1);
+
+ my $s6_res = $ws->search(artist => { artist => 'Van Halen', type => 'group' });
+ exit_if_mb_busy($s6_res);
+-ok($s6_res->{count} == 1);
++ok($s6_res->{count} >= 1);
+ ok($s6_res->{artists}->[0]->{type} eq 'Group');
+ ok($s6_res->{artists}->[0]->{id} eq 'b665b768-0d83-4363-950c-31ed39317c15');
+ sleep(1);