aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorptrcnull <git@ptrcnull.me>2024-03-28 18:20:20 +0100
committerptrcnull <git@ptrcnull.me>2024-03-28 18:20:20 +0100
commit621818d28c7c7516a568bc4a185bc2b361b11a13 (patch)
tree4bb35811fd8062f7c23e30971e8798c51cf66f27
parentbb3d061b8c3ec7552dd161d37991eb06dcc31e76 (diff)
community/rss2email: build with gpep517HEADmaster
also fix a small test failure with newer dependency
-rw-r--r--community/rss2email/APKBUILD18
-rw-r--r--community/rss2email/html2text-space.patch24
-rw-r--r--community/rss2email/poetry-core.patch41
3 files changed, 78 insertions, 5 deletions
diff --git a/community/rss2email/APKBUILD b/community/rss2email/APKBUILD
index 153b95a7a30..b65eece7ed1 100644
--- a/community/rss2email/APKBUILD
+++ b/community/rss2email/APKBUILD
@@ -3,20 +3,25 @@
# Maintainer: Galen Abell <galen@galenabell.com>
pkgname=rss2email
pkgver=3.14
-pkgrel=0
+pkgrel=1
pkgdesc="Forward RSS feeds to your email address, community maintained"
url="https://github.com/rss2email/rss2email"
arch="noarch"
license="GPL-2.0-only"
depends="python3 py3-feedparser py3-html2text py3-beautifulsoup4"
-makedepends="py3-setuptools"
+makedepends="py3-gpep517 py3-poetry-core"
subpackages="$pkgname-pyc"
-source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/r/rss2email/rss2email-$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/r/rss2email/rss2email-$pkgver.tar.gz
+ poetry-core.patch
+ html2text-space.patch
+ "
replaces="py3-rss2email"
provides="py3-rss2email=$pkgver-r$pkgrel"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
@@ -25,9 +30,12 @@ check() {
}
package() {
- python3 setup.py install --skip-build --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
e5da76894d315621bd097d907cbb99e5ecb0f3f8c0fc10ca619577cc08d66e38e47aec38d96d719b3ff2309056c79d7e33fa9feecd6de9b6d950da3ef39533ed rss2email-3.14.tar.gz
+237a2e111c37ac86b168e51949398fc635e80def80f814f14de0ffa6e842e464f2231b4c421d02ec704490031408769543e32ad16bf0ab7eefeb29d8c2c32f4c poetry-core.patch
+5dd211b053eabf0a098c0d455f9e30b611ece12e9d077f1cde04c9ae9dc4e5f49e9c0cac8e208dcf6b226b77d70a27b150c289d51e5b9c8839dd44113db6db1a html2text-space.patch
"
diff --git a/community/rss2email/html2text-space.patch b/community/rss2email/html2text-space.patch
new file mode 100644
index 00000000000..b797f9d00d9
--- /dev/null
+++ b/community/rss2email/html2text-space.patch
@@ -0,0 +1,24 @@
+From b5c0e78006c2db6929b5ff50e8529de58a00412a Mon Sep 17 00:00:00 2001
+From: auouymous <au@qzx.com>
+Date: Fri, 8 Mar 2024 15:50:04 -0700
+Subject: [PATCH] Replace a "c2 a0" utf-8 sequence in test feed with a space.
+
+This caused html2text >=2024.2.25 to produce a double space and break
+the tests.
+---
+ test/data/allthingsrss/feed.atom | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/test/data/allthingsrss/feed.atom b/test/data/allthingsrss/feed.atom
+index 074847b..0cf8c33 100644
+--- a/test/data/allthingsrss/feed.atom
++++ b/test/data/allthingsrss/feed.atom
+@@ -47,7 +47,7 @@
+ &lt;/ul&gt;
+ &lt;p&gt;Complete list in the official &lt;a href="http://www.allthingsrss.com/rss2email/changelog"&gt;CHANGELOG&lt;/a&gt;.&lt;/p&gt;
+ &lt;p&gt;&lt;strong&gt;Pause/Unpause&lt;/strong&gt;&lt;/p&gt;
+-&lt;p&gt;Through &lt;code&gt;r2e pause &lt;em&gt;n&lt;/em&gt;&lt;/code&gt; where &lt;em&gt;n&lt;/em&gt; is a feed number, you can temporarily suspend checking that feed for new content. To start checking it again, simply run &lt;code&gt;r2e unpause &lt;em&gt;n&lt;/em&gt;&lt;/code&gt;. When you &lt;code&gt;r2e list&lt;/code&gt;, an asterisk indicates that the feed is currently unpaused and active.&lt;/p&gt;
++&lt;p&gt;Through &lt;code&gt;r2e pause &lt;em&gt;n&lt;/em&gt;&lt;/code&gt; where &lt;em&gt;n&lt;/em&gt; is a feed number, you can temporarily suspend checking that feed for new content. To start checking it again, simply run &lt;code&gt;r2e unpause &lt;em&gt;n&lt;/em&gt;&lt;/code&gt;. When you &lt;code&gt;r2e list&lt;/code&gt;, an asterisk indicates that the feed is currently unpaused and active.&lt;/p&gt;
+
+ &lt;p&gt;&lt;a href="http://feedads.g.doubleclick.net/~a/nYgTsIUsS9pmvRZ6092XGGHnNKg/0/da"&gt;&lt;img src="http://feedads.g.doubleclick.net/~a/nYgTsIUsS9pmvRZ6092XGGHnNKg/0/di" border="0" ismap="true"&gt;&lt;/img&gt;&lt;/a&gt;&lt;br/&gt;
+ &lt;a href="http://feedads.g.doubleclick.net/~a/nYgTsIUsS9pmvRZ6092XGGHnNKg/1/da"&gt;&lt;img src="http://feedads.g.doubleclick.net/~a/nYgTsIUsS9pmvRZ6092XGGHnNKg/1/di" border="0" ismap="true"&gt;&lt;/img&gt;&lt;/a&gt;&lt;/p&gt;&lt;img src="http://feeds.feedburner.com/~r/allthingsrss/hJBr/~4/bT-I0iH2vw8" height="1" width="1"/&gt;</content>
diff --git a/community/rss2email/poetry-core.patch b/community/rss2email/poetry-core.patch
new file mode 100644
index 00000000000..4dfc8d7b04f
--- /dev/null
+++ b/community/rss2email/poetry-core.patch
@@ -0,0 +1,41 @@
+From 183a17aefe4eb66f898cf088519b1e845559f2bd Mon Sep 17 00:00:00 2001
+From: "Daniel M. Capella" <polyzen@archlinux.org>
+Date: Sun, 23 Oct 2022 20:06:25 -0400
+Subject: [PATCH] Use poetry-core as build-backend
+
+From https://archlinux.org/todo/use-correct-pep517-build-system/:
+
+> The build environments in use for the various PEP517 capable tooling
+> (e.g. flit, pdm, poetry) are not part of the respective tooling (but
+> each tooling require theirs).
+>
+> Updating Python will become a more complex task in the future, as we
+> have to bootstrap the respective PEP517 backends. To not also bootstrap
+> the respective PEP517 capable tooling, please make sure to only use
+> their respective backend in makedepends:
+>
+> python-flit -> python-flit-core
+> python-poetry -> python-poetry-core
+> python-pdm -> python-pdm-pep517
+>
+> In case this is wrongly stated in the upstream pyproject.toml, make
+> sure to supply a fix to upstream.
+---
+ pyproject.toml | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/pyproject.toml b/pyproject.toml
+index 6a14265..b670947 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -14,8 +14,8 @@ html2text = ">=2020.1.16"
+ update-copyright = ">=0.6.2"
+
+ [build-system]
+-requires = ["poetry>=0.12"]
+-build-backend = "poetry.masonry.api"
++requires = ["poetry-core>=1.0.0"]
++build-backend = "poetry.core.masonry.api"
+
+ [tool.poetry.scripts]
+ r2e = "rss2email.main:run"