aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2024-04-24 12:15:49 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2024-04-24 12:16:32 +0200
commitcabbeee0bdcebfea80986126664a649cc7942022 (patch)
tree24bf9e5146c7e962b3113e02e76f73b454869cf9
parent9d91220a88e5ede9ef6a8633c71cd27db69acd7b (diff)
community/jupyter-server: disable test that fails on riscv64HEADmaster
FAILED tests/test_gateway.py::test_gateway_request_with_expiring_cookies[True-Expires-Wed, 24 Apr 2024 10:10:47 +0000-None-True] - TypeError: argument of type 'NoneType' is not iterable
-rw-r--r--community/jupyter-server/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/community/jupyter-server/APKBUILD b/community/jupyter-server/APKBUILD
index adf3c372b5c..dbfc6d217c9 100644
--- a/community/jupyter-server/APKBUILD
+++ b/community/jupyter-server/APKBUILD
@@ -69,6 +69,7 @@ check() {
# test_delete_non_empty_folder not raising HTTPError on x86 & x86_64 builders
# test_api 500 errors under certain builder state repeatedly (why?)
# test_restart_kernel fails on x86 with a 1!=0 assert
+ # test_gateway_request_with_expiring_cookies fails on riscv64: TypeError: argument of type 'NoneType' is not iterable
pytest \
--disable-warnings \
-W ignore::DeprecationWarning \
@@ -79,8 +80,8 @@ check() {
--deselect tests/services/contents/test_manager.py::test_copy_big_dir \
--deselect tests/services/contents/test_manager.py::test_delete_non_empty_folder \
--deselect tests/services/contents/test_api.py \
- --deselect tests/services/sessions/test_api.py::test_restart_kernel
-
+ --deselect tests/services/sessions/test_api.py::test_restart_kernel \
+ --deselect tests/test_gateway.py::test_gateway_request_with_expiring_cookies
}
package() {