aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2024-04-19 21:18:06 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2024-04-20 00:09:47 +0200
commit536a94b7dde14800f77d527571fc734284b43d18 (patch)
tree1a8cb5baba491aa409c5e78be665da80e6a5c4a6
parent3d9cd5d0eda0cecf948f77172287c321aae69b2a (diff)
main/util-linux: fix makedependency for bootstrap buildHEADmaster
we need bash for tools/all_syscalls script.
-rw-r--r--main/util-linux/APKBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/main/util-linux/APKBUILD b/main/util-linux/APKBUILD
index bff51a71f06..28b133102fd 100644
--- a/main/util-linux/APKBUILD
+++ b/main/util-linux/APKBUILD
@@ -3,15 +3,16 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=util-linux
pkgver=2.40
-pkgrel=1
+pkgrel=2
pkgdesc="Random collection of Linux utilities"
url="https://git.kernel.org/cgit/utils/util-linux/util-linux.git"
arch="all"
license="GPL-3.0-or-later AND GPL-2.0-or-later AND GPL-2.0-only AND
GPL-1.0-only AND LGPL-2.1-or-later AND LGPL-1.0-only AND BSD-1-Clause AND
BSD-3-Clause AND BSD-4-Clause-UC AND MIT AND Public-Domain"
-checkdepends="bash findutils xz"
+checkdepends="findutils xz"
makedepends_host="
+ bash
libcap-ng-dev
linux-headers
ncurses-dev
@@ -51,7 +52,7 @@ subpackages="
wipefs:_mv_bin
"
if [ -z "$BOOTSTRAP" ] && [ -z "$APORTS_BOOTSTRAP" ]; then
- checkdepends="bash findutils xz procps coreutils"
+ checkdepends="findutils xz procps coreutils"
makedepends_build="$makedepends_build asciidoctor"
makedepends_host="$makedepends_host
linux-pam-dev
@@ -125,7 +126,7 @@ prepare() {
}
build() {
- if [ -z "$BOOTSTRAP" ] && [ -z "$APORTS_BOOTSTRAP" ]; then
+ if [ -z "$BOOTSTRAP" ]; then
# Linking utmps statically is strongly preferred by the utmps author
# and also much more space efficient - adds 4 kiB to each binary, that's
# 20 kiB in total for util-linux-*, versus 196 kiB (libskarnet.so).
@@ -150,7 +151,6 @@ build() {
--with-vendordir=/usr/lib \
--enable-fs-paths-extra=/usr/sbin \
$_bootstrap_config
- make tools/all_syscalls
make
}