aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCeleste <20312-Celeste@users.gitlab.alpinelinux.org>2024-04-24 02:18:57 +0000
committerCeleste <20312-Celeste@users.gitlab.alpinelinux.org>2024-04-24 02:42:14 +0000
commit3505047f5453c664ed23eb81bb35ddaabb97b2dd (patch)
tree07b9f045b81195f42a6c5d92bdfc0f1e23121c15
parenta011b2ad29a38321cbc6abceabc4c871965eaacc (diff)
main/cache: unset setgid bit to fix tests on riscv64 builderHEADmaster
Similar to what was done in 6613d926183b79c1d5bd4b53d99564a1165bcfbe
-rw-r--r--main/ccache/APKBUILD8
1 files changed, 8 insertions, 0 deletions
diff --git a/main/ccache/APKBUILD b/main/ccache/APKBUILD
index a6142afaf90..3b3db4886ea 100644
--- a/main/ccache/APKBUILD
+++ b/main/ccache/APKBUILD
@@ -24,6 +24,14 @@ source="https://github.com/ccache/ccache/releases/download/v$pkgver/ccache-$pkgv
system-xxhash.patch
"
+prepare() {
+ default_prepare
+
+ # The riscv64 builder seems to have setgid bit set,
+ # which causes tests 2, 22, and 34 to fail.
+ chmod -v -s .
+}
+
build() {
cmake -B build -G Ninja \
-DCCACHE_DEV_MODE=OFF \