aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCeleste <20312-Celeste@users.gitlab.alpinelinux.org>2024-05-13 13:52:39 +0000
committerCeleste <20312-Celeste@users.gitlab.alpinelinux.org>2024-05-13 14:21:03 +0000
commit51fcb8f8adb2fb5e4ced393e693d547bc069f8fb (patch)
tree2c5cb8eff9d46a654a4c1bdea4f189677512072b
parent67057bc8126842a38e42e8640e79c5aac2785c4b (diff)
community/gnome-authenticator: do not compile tests with mesonHEADmaster
slow architectures exceed the 10-minute timeout and fail
-rw-r--r--community/gnome-authenticator/APKBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/community/gnome-authenticator/APKBUILD b/community/gnome-authenticator/APKBUILD
index 7c6bf02f254..15736847109 100644
--- a/community/gnome-authenticator/APKBUILD
+++ b/community/gnome-authenticator/APKBUILD
@@ -35,6 +35,11 @@ build() {
}
check() {
+ # Compile tests before running them with Meson to avoid timeout
+ CARGO_TARGET_DIR="$builddir"/output/target \
+ CARGO_HOME="$CARGO_TARGET_DIR"/cargo-home \
+ cargo test --no-run --bin authenticator
+
meson test --no-rebuild --print-errorlogs -C output
}