aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorptrcnull <git@ptrcnull.me>2024-03-28 14:15:07 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2024-03-28 14:54:10 +0000
commit873093de0e90852132c8d36f40a436db5179586e (patch)
tree75a7f47953982ee5489fad23501f8bfbf076e775
parent58f9b9b2e4f45fedb21fe1c80ee4f945c7eb6ac5 (diff)
community/py3-terminado: fix tests with python 3.12HEADmaster
-rw-r--r--community/py3-terminado/APKBUILD2
-rw-r--r--community/py3-terminado/ResourceWarning.patch10
2 files changed, 12 insertions, 0 deletions
diff --git a/community/py3-terminado/APKBUILD b/community/py3-terminado/APKBUILD
index e9a40d3adeb..748ec76c5f9 100644
--- a/community/py3-terminado/APKBUILD
+++ b/community/py3-terminado/APKBUILD
@@ -13,6 +13,7 @@ checkdepends="py3-pytest py3-pytest-timeout"
subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/jupyter/terminado/archive/refs/tags/v$pkgver.tar.gz
bash.patch
+ ResourceWarning.patch
"
builddir="$srcdir/terminado-$pkgver/"
@@ -34,4 +35,5 @@ package() {
sha512sums="
8b82fce407424ed5061c24121f37f851006e1c1420a2dee5deb3590221dd04c33486efb7f9dfd2216522465fddc275d29520f75ba97248a40b2c9d533841eea4 py3-terminado-0.18.0.tar.gz
3e731470ad7d1a5f833e94f0912e2e1941d5337ff52016f94b5a918c78e8b0408aa01b2cba4d6ace64c3f64bc89a7e0e4f8319925afe8e4df00ed480a43fe29b bash.patch
+10528d797a0c06ccf8eddae7aa5d8e76f999f5b3d96f498298656b214696b943fd269cce7ff6cbe24ad8335aed02ec16af11e8408e275a2841f2c2fb32a76710 ResourceWarning.patch
"
diff --git a/community/py3-terminado/ResourceWarning.patch b/community/py3-terminado/ResourceWarning.patch
new file mode 100644
index 00000000000..b868e951ed2
--- /dev/null
+++ b/community/py3-terminado/ResourceWarning.patch
@@ -0,0 +1,10 @@
+diff --git a/pyproject.toml b/pyproject.toml
+index 171b561..709640e 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -75,4 +75,3 @@ timeout = 300
+ filterwarnings = [
+- "error",
+- "module:unclosed <socket.socket:ResourceWarning",
++ "default:unclosed <socket.socket:ResourceWarning",
+ ]