aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorptrcnull <git@ptrcnull.me>2024-03-28 09:52:38 +0100
committerptrcnull <git@ptrcnull.me>2024-03-28 09:52:46 +0100
commit54f0c34ef6fc3785864431b3de4f599e302d037d (patch)
tree3e5cf63c10469e20bb94abf9645d48635af93316
parent6227203eb75bb57ef3ca1baa4cd9018b68a422b1 (diff)
testing/py3-tailer: moderniseHEADmaster
-rw-r--r--testing/py3-tailer/APKBUILD21
1 files changed, 13 insertions, 8 deletions
diff --git a/testing/py3-tailer/APKBUILD b/testing/py3-tailer/APKBUILD
index 63364e51fab..b5a36337173 100644
--- a/testing/py3-tailer/APKBUILD
+++ b/testing/py3-tailer/APKBUILD
@@ -1,24 +1,29 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-tailer
-_pkgname=tailer
pkgver=0.4.1
-pkgrel=5
+pkgrel=6
pkgdesc="Python tail is a simple implementation of GNU tail and head"
url="https://github.com/six8/pytailer"
arch="noarch"
license="MIT"
-depends="python3"
+makedepends="py3-gpep517 py3-wheel py3-setuptools"
subpackages="$pkgname-pyc"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+source="https://files.pythonhosted.org/packages/source/t/tailer/tailer-$pkgver.tar.gz"
+builddir="$srcdir/tailer-$pkgver"
+options="!check" # no tests provided
-builddir="$srcdir"/$_pkgname-$pkgver
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --skip-build --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="c1f0f4cf9356c58366e3d86087bc922378a5d5d9833385e8b0f9acd16211a7ff486c4ea3be13208b85a9766b3fa163071216de54c7170395c18ba6da61650da3 tailer-0.4.1.tar.gz"
+sha512sums="
+c1f0f4cf9356c58366e3d86087bc922378a5d5d9833385e8b0f9acd16211a7ff486c4ea3be13208b85a9766b3fa163071216de54c7170395c18ba6da61650da3 tailer-0.4.1.tar.gz
+"