aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2024-04-18 17:13:40 +0000
committerMilan P. Stanić <mps@arvanta.net>2024-04-18 17:13:40 +0000
commit68ca743ce07189aaf29a3d1c5f1ba27b47dc7423 (patch)
treedb11d1588ffd922729c0a9f1ec69ee117bef5a4f
parent31ac69aaa4aacb50e9233be0eb47a23e94157afa (diff)
community/linux-edge: upgrade to 6.8.7HEADmaster
enable PSI but disable by default
-rw-r--r--community/linux-edge/APKBUILD12
-rw-r--r--community/linux-edge/config-edge.aarch645
-rw-r--r--community/linux-edge/config-edge.armv75
-rw-r--r--community/linux-edge/config-edge.riscv645
-rw-r--r--community/linux-edge/config-edge.x86_649
5 files changed, 19 insertions, 17 deletions
diff --git a/community/linux-edge/APKBUILD b/community/linux-edge/APKBUILD
index dde1cf2a15e..52fe7beb17c 100644
--- a/community/linux-edge/APKBUILD
+++ b/community/linux-edge/APKBUILD
@@ -4,7 +4,7 @@ _flavor=edge
pkgname=linux-${_flavor}
# NOTE: this kernel is intended for testing
# please resist urge to upgrade it blindly
-pkgver=6.8.6
+pkgver=6.8.7
case $pkgver in
*.*.*) _kernver=${pkgver%.*};;
*.*) _kernver=$pkgver;;
@@ -266,9 +266,9 @@ _doc() {
sha512sums="
5c4eb4aa1d3f7d1ea01c0f7ddeadacdece6e144fd4bdfc16b2b925d3e10dc04de3a6db69320b79a96c3560052616f001d2c09e7a1bb4f7b731e2380a7ecce068 linux-6.8.tar.xz
-92ce796b5c66c532072d000e9b01882ed1729b0f29dc5587029505cbdd6f398dad71023aaa8ab1d6e268431868d93230a5a5532621ce00296d9567ad744c0d77 patch-6.8.6.xz
-cebf11a76ffe41b3cfb10a8bc9716165aedfc20394668da13b3ede1a409ebdf488f6949469883cda510365b82982143ba9a8f964a5840365e23e6adcd4faa4dc config-edge.aarch64
-71f07a19eab9e0997385546b2eb1e6fcbced770db316a6a053b0f683ae57d4e698a8f5bb7d2c4c9a1e7cdb8453bfe7eb7ea4ce829819fa3bd626383e3010caa1 config-edge.armv7
-2211c95463c2f761634635bbc5fcb658f20c89739b2075e316aedb1363fa18b02a52fb18ab60ea24638e706acd2e8dd8ba213271ca289cf1f81bb351ad600d51 config-edge.x86_64
-cd3cf86c4ef6e5fdb7710dbe706afef61e7a5af36db55681b1230b167f36a7e08341ff3b7cb131e86ea4a503115ba09c91c7d10dba7f436b0c045bed37d89b8b config-edge.riscv64
+19f6ff889e643bd46bce57ff9312900ab2bf866a8c2eaf0ab545bd6f4189872346c861672babbff991dbb04e3ef1a9b805aaac491d660482bdedc30af5922a0c patch-6.8.7.xz
+bb50b625a8ad09437cdc9728db390329a19a1f1133d399de59defa57cf598ab7eeda9e00cbbbe2788fd880bf64e8adc2a7d50e9749a4c279b0f86900edf0b33f config-edge.aarch64
+305a6916440027d1247b39d504acfe544de798a0ed20b52ba5c18c6541066edc362ace8d5d208ce33994c3732366c0fffe94ab1983785d098f97cf80152899ed config-edge.armv7
+e66c2f8801e2f30a594479cfc2f3a8e794531f5d6521b7ab32171a0fd207c2b8472dc7c2efa289a3ae49248585eb7fb60cc73afa05ef6d7beb79b222600ba5f3 config-edge.x86_64
+91fc33060be048e9a2cee820f5502cec14782eff285bfb1da556d4e53b9e2df7c8d25539a7f634a9b1d59a308964075d9c473f0eba0cd2afb540fd446b2fa796 config-edge.riscv64
"
diff --git a/community/linux-edge/config-edge.aarch64 b/community/linux-edge/config-edge.aarch64
index eec42a7177e..28867a7d348 100644
--- a/community/linux-edge/config-edge.aarch64
+++ b/community/linux-edge/config-edge.aarch64
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/arm64 6.8.6 Kernel Configuration
+# Linux/arm64 6.8.7 Kernel Configuration
#
CONFIG_CC_VERSION_TEXT="gcc (Alpine 13.2.1_git20240309) 13.2.1 20240309"
CONFIG_CC_IS_GCC=y
@@ -123,7 +123,8 @@ CONFIG_TASKSTATS=y
CONFIG_TASK_DELAY_ACCT=y
CONFIG_TASK_XACCT=y
CONFIG_TASK_IO_ACCOUNTING=y
-# CONFIG_PSI is not set
+CONFIG_PSI=y
+CONFIG_PSI_DEFAULT_DISABLED=y
# end of CPU/Task time and stats accounting
CONFIG_CPU_ISOLATION=y
diff --git a/community/linux-edge/config-edge.armv7 b/community/linux-edge/config-edge.armv7
index d9469495828..64dc787de8d 100644
--- a/community/linux-edge/config-edge.armv7
+++ b/community/linux-edge/config-edge.armv7
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/arm 6.8.6 Kernel Configuration
+# Linux/arm 6.8.7 Kernel Configuration
#
CONFIG_CC_VERSION_TEXT="gcc (Alpine 13.2.1_git20240309) 13.2.1 20240309"
CONFIG_CC_IS_GCC=y
@@ -127,7 +127,8 @@ CONFIG_TASKSTATS=y
CONFIG_TASK_DELAY_ACCT=y
CONFIG_TASK_XACCT=y
CONFIG_TASK_IO_ACCOUNTING=y
-# CONFIG_PSI is not set
+CONFIG_PSI=y
+CONFIG_PSI_DEFAULT_DISABLED=y
# end of CPU/Task time and stats accounting
CONFIG_CPU_ISOLATION=y
diff --git a/community/linux-edge/config-edge.riscv64 b/community/linux-edge/config-edge.riscv64
index dca1d654f55..be90e0457af 100644
--- a/community/linux-edge/config-edge.riscv64
+++ b/community/linux-edge/config-edge.riscv64
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/riscv 6.8.6 Kernel Configuration
+# Linux/riscv 6.8.7 Kernel Configuration
#
CONFIG_CC_VERSION_TEXT="gcc (Alpine 13.2.1_git20240309) 13.2.1 20240309"
CONFIG_CC_IS_GCC=y
@@ -117,7 +117,8 @@ CONFIG_TASKSTATS=y
CONFIG_TASK_DELAY_ACCT=y
CONFIG_TASK_XACCT=y
CONFIG_TASK_IO_ACCOUNTING=y
-# CONFIG_PSI is not set
+CONFIG_PSI=y
+CONFIG_PSI_DEFAULT_DISABLED=y
# end of CPU/Task time and stats accounting
CONFIG_CPU_ISOLATION=y
diff --git a/community/linux-edge/config-edge.x86_64 b/community/linux-edge/config-edge.x86_64
index 5f5876f0ff1..7132880ee0a 100644
--- a/community/linux-edge/config-edge.x86_64
+++ b/community/linux-edge/config-edge.x86_64
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86_64 6.8.6 Kernel Configuration
+# Linux/x86 6.8.7 Kernel Configuration
#
CONFIG_CC_VERSION_TEXT="gcc (Alpine 13.2.1_git20240309) 13.2.1 20240309"
CONFIG_CC_IS_GCC=y
@@ -144,7 +144,8 @@ CONFIG_TASKSTATS=y
CONFIG_TASK_DELAY_ACCT=y
CONFIG_TASK_XACCT=y
CONFIG_TASK_IO_ACCOUNTING=y
-# CONFIG_PSI is not set
+CONFIG_PSI=y
+CONFIG_PSI_DEFAULT_DISABLED=y
# end of CPU/Task time and stats accounting
CONFIG_CPU_ISOLATION=y
@@ -517,9 +518,7 @@ CONFIG_CPU_IBRS_ENTRY=y
CONFIG_SLS=y
# CONFIG_GDS_FORCE_MITIGATION is not set
CONFIG_MITIGATION_RFDS=y
-CONFIG_SPECTRE_BHI_ON=y
-# CONFIG_SPECTRE_BHI_OFF is not set
-# CONFIG_SPECTRE_BHI_AUTO is not set
+CONFIG_MITIGATION_SPECTRE_BHI=y
CONFIG_ARCH_HAS_ADD_PAGES=y
#