aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCeleste <20312-Celeste@users.gitlab.alpinelinux.org>2024-04-23 05:19:13 +0000
committerCeleste <20312-Celeste@users.gitlab.alpinelinux.org>2024-04-23 06:05:13 +0000
commit241bfcda91e4125d8d766cf929db6a970a720e24 (patch)
tree18a7bdc4c570134c5df947c5c155d52dd778128b
parent212b90c2ecd2dc9948df3bd58153ae2cf6aa0745 (diff)
testing/perl-json-path: upgrade to 1.0.5HEADmaster
-rw-r--r--testing/perl-json-path/APKBUILD11
-rw-r--r--testing/perl-json-path/no-tie-ixhash.patch36
2 files changed, 4 insertions, 43 deletions
diff --git a/testing/perl-json-path/APKBUILD b/testing/perl-json-path/APKBUILD
index 16a1ad84c1b..b98703283eb 100644
--- a/testing/perl-json-path/APKBUILD
+++ b/testing/perl-json-path/APKBUILD
@@ -2,10 +2,10 @@
# Contributor: Celeste <cielesti@protonmail.com>
# Maintainer: Celeste <cielesti@protonmail.com>
pkgname=perl-json-path
+pkgver=1.0.5
+pkgrel=0
#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
_pkgreal=JSON-Path
-pkgver=1.0.4
-pkgrel=0
pkgdesc="Search nested hashref/arrayref structures using JSONPath"
url="https://metacpan.org/release/JSON-Path/"
arch="noarch"
@@ -16,9 +16,7 @@ depends="
"
checkdepends="perl-test2-suite"
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/P/PO/POPEFELIX/JSON-Path-$pkgver.tar.gz
- no-tie-ixhash.patch
- "
+source="https://cpan.metacpan.org/authors/id/P/PO/POPEFELIX/JSON-Path-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
build() {
@@ -40,6 +38,5 @@ package() {
}
sha512sums="
-89819d9afb8302f1b07d5d8376614f406c6e47017aef42fa0a4064a2d843d21d5aec83451f05ef66e62cd9118ebed12761d601c498efe43fcf1fce60308ff15f JSON-Path-1.0.4.tar.gz
-77471715204552bd6c49b8ce0e7082b4cc4ea94a7d6c23bb9d32a04453a541de76ca7a40df82f3b2325bcb60e3ff05a5f0f79123184706b269bb6cb2f92e8358 no-tie-ixhash.patch
+baacf6d145245ad42ef41c0b9c77d527d0cb530e1df5c998e4b8c984f8009ddd792fa80a62ace29d7906ec1368b41418d8fb7c4a13d73693b3208dbb266f904a JSON-Path-1.0.5.tar.gz
"
diff --git a/testing/perl-json-path/no-tie-ixhash.patch b/testing/perl-json-path/no-tie-ixhash.patch
deleted file mode 100644
index f943faeb3af..00000000000
--- a/testing/perl-json-path/no-tie-ixhash.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-Patch-Source: https://github.com/PopeFelix/p5-json-path/commit/a042749fb2e0103c3fa58fc02b70992fe34be7a9.patch
---
-From a042749fb2e0103c3fa58fc02b70992fe34be7a9 Mon Sep 17 00:00:00 2001
-From: bernhard <Bernhard.Schmalhofer@gmx.de>
-Date: Mon, 11 Dec 2023 21:03:21 +0100
-Subject: [PATCH] Do not require Tie::IxHash
-
----
- cpanfile | 1 -
- t/evaluator/paths.t | 1 -
- 2 files changed, 2 deletions(-)
-
-diff --git a/cpanfile b/cpanfile
-index b1e5ff8..85eb5be 100644
---- a/cpanfile
-+++ b/cpanfile
-@@ -6,7 +6,6 @@ requires 'List::Util' => '1.45'; # For uniq.
- requires 'Readonly';
- requires 'Try::Tiny';
- requires 'perl' => '5.010';
--requires 'Tie::IxHash';
-
- on test => sub {
- requires 'Test2::V0';
-diff --git a/t/evaluator/paths.t b/t/evaluator/paths.t
-index 6db78ae..3e301af 100644
---- a/t/evaluator/paths.t
-+++ b/t/evaluator/paths.t
-@@ -2,7 +2,6 @@ use Test2::V0;
- use JSON::MaybeXS qw/encode_json decode_json/;
- use JSON::Path::Evaluator;
- use Storable qw(dclone);
--use Tie::IxHash;
-
- my $json = sample_json();
- my %data = %{ decode_json($json) };