aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCeleste <20312-Celeste@users.gitlab.alpinelinux.org>2024-04-25 02:03:22 +0000
committerCeleste <20312-Celeste@users.gitlab.alpinelinux.org>2024-04-25 02:18:17 +0000
commitc62e1fef0d0362f075e45e484de2fae77842d243 (patch)
tree6430b0dd166842b050122e57cb4f02c850aba2f2
parent38b444cfe30fb6df84d553e075ea0dcbae798cb6 (diff)
community/perl-mail-sendmail: fix fake-smtp.py test helperHEADmaster
`smtpd` and `asyncore` moved to `test.support` in Python 3.12 also, make some style changes that are in line with apkbuild-cpan template 4, but don't upgrade to that yet, as it needs a pkgrel bump to remove empty dirs
-rw-r--r--community/perl-mail-sendmail/APKBUILD15
-rw-r--r--community/perl-mail-sendmail/fake-smtp.py4
2 files changed, 11 insertions, 8 deletions
diff --git a/community/perl-mail-sendmail/APKBUILD b/community/perl-mail-sendmail/APKBUILD
index 1e003905845..375839cd362 100644
--- a/community/perl-mail-sendmail/APKBUILD
+++ b/community/perl-mail-sendmail/APKBUILD
@@ -2,19 +2,20 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Maintainer: Valery Kartel <valery.kartel@gmail.com>
pkgname=perl-mail-sendmail
-_pkgreal=Mail-Sendmail
pkgver=0.80
pkgrel=5
+_pkgreal=Mail-Sendmail
pkgdesc="Simple platform independent mailer"
url="https://metacpan.org/release/Mail-Sendmail/"
arch="noarch"
license="GPL-1.0-or-later OR Artistic-1.0-Perl"
depends="perl"
-checkdepends="python3"
+checkdepends="python3 python3-tests"
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/N/NE/NEILB/$_pkgreal-$pkgver.tar.gz
+source="https://cpan.metacpan.org/authors/id/N/NE/NEILB/Mail-Sendmail-$pkgver.tar.gz
test-localhost.patch
- fake-smtp.py"
+ fake-smtp.py
+ "
builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
@@ -46,6 +47,8 @@ package() {
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="848ec471938d679645dfb4e032a33d35e49655a336dc6ff3a24ffa35606bff77e73162af672d1a60ad3a7bf571113e802fc42d6cb9a072cdca0d89f707f54a08 Mail-Sendmail-0.80.tar.gz
+sha512sums="
+848ec471938d679645dfb4e032a33d35e49655a336dc6ff3a24ffa35606bff77e73162af672d1a60ad3a7bf571113e802fc42d6cb9a072cdca0d89f707f54a08 Mail-Sendmail-0.80.tar.gz
2592c4aafd9f58d9e4f8c0f78e8d87e7e6160b4a53aa73b929ad12d26d677f8a7baec540a57a8edabbba6f05bd33c9e2dc5ee707cfaaccd14837a6ddc681d742 test-localhost.patch
-dbff85dc3924274c2f640e0f6ea4d782c0221e841763fb122c9942ef8e2c5d7a0c73aa2cfd1f7b59708fe27a392a000dcfbc2a04ad7e7e8885d21a27df339410 fake-smtp.py"
+22dbe3e35c9112fd61024b1636c30c3a2a9803f63ba0017a43ec13cfdaa3e80c99ee6b3b154fac64d8e2e170655e4235e369c3189c8938362cbb6ed1687fe033 fake-smtp.py
+"
diff --git a/community/perl-mail-sendmail/fake-smtp.py b/community/perl-mail-sendmail/fake-smtp.py
index 25929d9b8a6..2f9b9176755 100644
--- a/community/perl-mail-sendmail/fake-smtp.py
+++ b/community/perl-mail-sendmail/fake-smtp.py
@@ -1,5 +1,5 @@
-import smtpd
-import asyncore
+from test.support import smtpd
+from test.support import asyncore
class FakeSMTPServer(smtpd.SMTPServer):
"""A Fake smtp server"""