aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2024-04-24 16:48:14 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2024-04-24 16:48:14 +0200
commitf39d5097bea5f5a89f428891d95feeff6eee58cc (patch)
tree1e7de6cdb003fd007588fcd1404ef1d9b424c7b2
parent533616f71041ab2958caed50e4640685a486885d (diff)
community/afl++: disable tests on riscv64HEADmaster
llvm LTO test fails on riscv64 and it seems not to be any easy way to skip it for a given architecture. Lets skip all for now. https://github.com/AFLplusplus/AFLplusplus/issues/2064
-rw-r--r--community/afl++/APKBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/community/afl++/APKBUILD b/community/afl++/APKBUILD
index 0a0e2d76671..fa8d3a8ece1 100644
--- a/community/afl++/APKBUILD
+++ b/community/afl++/APKBUILD
@@ -12,6 +12,11 @@ arch="all !armhf !armv7 !s390x !x86"
license="Apache-2.0"
# afl-cmin requires stat
_llvmver=17
+# llvm LTO test fails on riscv64
+# https://github.com/AFLplusplus/AFLplusplus/issues/2064
+case "$CARCH" in
+ riscv64) options="$options !check";;
+esac
depends="
clang$_llvmver
compiler-rt