aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorptrcnull <git@ptrcnull.me>2024-03-28 19:34:32 +0100
committerptrcnull <git@ptrcnull.me>2024-03-28 19:34:32 +0100
commit3b99b423581d6a7c7d10bc2a4f27b29b9e132594 (patch)
treed145b39bef4d8fbd1e1eaa91fe1019b6ea331571
parentb16fd211ba0c68153e6daa85054f11b8c40d8330 (diff)
community/py3-loky: disable even more testsHEADmaster
in preparation for python 3.12
-rw-r--r--community/py3-loky/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/community/py3-loky/APKBUILD b/community/py3-loky/APKBUILD
index 5c7ffac281f..6af0a457ee4 100644
--- a/community/py3-loky/APKBUILD
+++ b/community/py3-loky/APKBUILD
@@ -31,7 +31,12 @@ check() {
--deselect tests/test_process_executor_forkserver.py::TestsProcessPoolForkserverExecutor::test_no_failure_on_large_data_send \
--deselect tests/test_process_executor_loky.py::TestsProcessPoolLokyExecutor::test_no_failure_on_large_data_send \
--deselect tests/test_process_executor_spawn.py::TestsProcessPoolSpawnExecutor::test_no_failure_on_large_data_send \
- --deselect tests/test_loky_backend.py::test_recursive_terminate
+ --deselect tests/test_loky_backend.py::test_recursive_terminate \
+ --deselect tests/test_resource_tracker.py::TestResourceTracker::test_resource_tracker_sigkill \
+ --deselect tests/test_reusable_executor.py::TestExecutorDeadLock::test_deadlock_kill \
+ --deselect tests/test_reusable_executor.py::TestResizeExecutor::test_resize_after_timeout \
+ --deselect tests/test_reusable_executor.py::test_no_crash_max_workers_on_windows \
+ --deselect tests/test_worker_timeout.py::TestTimeoutExecutor::test_worker_timeout_shutdown_no_deadlock
}
package() {