aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntoine Martin <dev@ayakael.net>2024-04-20 18:07:13 -0400
committeromni <omni+alpine@hack.org>2024-04-25 01:02:11 +0000
commitb297172fae3244849151ac293b7eecee6c1288ce (patch)
tree912ba0ecbd1c028bbc1527c05e499c5ce1a63941
parent4c5c4619d0b196119d7790d492a440d22324d88f (diff)
community/py3-daphne: upgrade to 4.1.2, fix check()HEADmaster
-rw-r--r--community/py3-daphne/0001-pytest-runner-extra.patch14
-rw-r--r--community/py3-daphne/APKBUILD39
2 files changed, 23 insertions, 30 deletions
diff --git a/community/py3-daphne/0001-pytest-runner-extra.patch b/community/py3-daphne/0001-pytest-runner-extra.patch
deleted file mode 100644
index 7cbb141aaa2..00000000000
--- a/community/py3-daphne/0001-pytest-runner-extra.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/setup.py b/setup.py
-index ae19f5d..636c5d5 100755
---- a/setup.py
-+++ b/setup.py
-@@ -24,8 +24,7 @@ setup(
- include_package_data=True,
- install_requires=["twisted[tls]>=22.4", "autobahn>=22.4.2", "asgiref>=3.5.2,<4"],
- python_requires=">=3.7",
-- setup_requires=["pytest-runner"],
-- extras_require={"tests": ["hypothesis", "pytest", "pytest-asyncio", "django"]},
-+ extras_require={"tests": ["pytest-runner","hypothesis", "pytest", "pytest-asyncio", "django"]},
- entry_points={
- "console_scripts": ["daphne = daphne.cli:CommandLineInterface.entrypoint"]
- },
diff --git a/community/py3-daphne/APKBUILD b/community/py3-daphne/APKBUILD
index 186bb7904bc..1cb7b42be89 100644
--- a/community/py3-daphne/APKBUILD
+++ b/community/py3-daphne/APKBUILD
@@ -1,9 +1,9 @@
# Contributor: Alex Denes <caskd@redxen.eu>
# Maintainer: Antoine Martin (ayakael) <dev@ayakael.net>
-_pkgname=daphne
-pkgname="py3-$_pkgname"
-pkgver=4.0.0
-pkgrel=2
+pkgname=py3-daphne
+_pkgreal=daphne
+pkgver=4.1.2
+pkgrel=0
pkgdesc="HTTP, HTTP2 and WebSocket protocol server for ASGI and ASGI-HTTP"
url="https://github.com/django/daphne"
arch="noarch"
@@ -15,33 +15,40 @@ depends="
"
checkdepends="
py3-hypothesis
+ py3-django
py3-cryptography
py3-pytest
py3-pytest-asyncio
py3-pytest-runner
"
-makedepends="py3-setuptools_scm"
-subpackages="$pkgname-pyc"
-source="
- https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
- 0001-pytest-runner-extra.patch
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-setuptools_scm
+ py3-wheel
"
-options="!check" # tests attempt to build checkdepends
-builddir="$srcdir/$_pkgname-$pkgver"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/django/daphne/archive/refs/tags/$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgreal-$pkgver
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -v
}
package() {
- python3 setup.py install --root "$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
+
sha512sums="
-1c7f707c3368fcc5c30fbb930effeb0ba1823727692514add4e6438082c9d02300a9031b56d432c1359f8f8299b0af2b925f3f9f32b4c365700f79052606676f daphne-4.0.0.tar.gz
-1b754db1ca81768d1026db567fcd0ca4b6695389144a70d20ebca8a7615bd13d271529e522b3e8fa897a36827428765a5952470b2420f42f98d00400eeaa7c34 0001-pytest-runner-extra.patch
+2be34cd2474068a31bd88363d4f9a4c0bb1f3209c52e9381e67649c6d4ca4f08186481ee57f59fd70689340e3fda287cc4907c1dc4dccd109b1c37119b30b9f2 py3-daphne-4.1.2.tar.gz
"