aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/afl++/APKBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/community/afl++/APKBUILD b/community/afl++/APKBUILD
index 0a0e2d76671..fa8d3a8ece1 100644
--- a/community/afl++/APKBUILD
+++ b/community/afl++/APKBUILD
@@ -12,6 +12,11 @@ arch="all !armhf !armv7 !s390x !x86"
license="Apache-2.0"
# afl-cmin requires stat
_llvmver=17
+# llvm LTO test fails on riscv64
+# https://github.com/AFLplusplus/AFLplusplus/issues/2064
+case "$CARCH" in
+ riscv64) options="$options !check";;
+esac
depends="
clang$_llvmver
compiler-rt