aboutsummaryrefslogblamecommitdiffstats
path: root/community/flatpak/APKBUILD
blob: 17f25c2b600d36ef09dcd2ec6c04452a6210087a (plain) (tree)
1
2
3
4
5
6
7
8
9
                                               
                                                    
                                                   
               
            
        
                                                           
                         
          
                           
                    
                                                                      



                                                             
                                                 
                                                                                             
                                 
                                                        
 



                      
         










                                                

                                                 
 



            
                     


           
                                      

 
                                                                                                                                                                  
                                                                                                                                                   
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
# Contributor: André Klitzing <aklitzing@gmail.com>
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=flatpak
pkgver=1.4.0
pkgrel=1
pkgdesc="Application deployment framework for desktop apps"
url="https://flatpak.org"
arch="all"
license="LGPL-2.1-or-later"
depends="bubblewrap"
makedepends="glib-dev libarchive-dev libsoup-dev libcap-dev polkit-dev
	libxau-dev ostree-dev>=2018.08 fuse-dev json-glib-dev
	libgcab-dev appstream-glib-dev dconf-dev
	libseccomp-dev libxslt-dev gpgme-dev bison"
subpackages="$pkgname-dev $pkgname-lang"
install="flatpak.pre-install flatpak.pre-upgrade"
source="https://github.com/flatpak/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.xz
		musl-fixes.patch"
options="suid !check" # Tests fail with no error message

# secfixes:
#   1.2.4-r0:
#     - CVE-2019-10063

build() {
	./configure \
		--build=$CBUILD \
		--host=$CHOST \
		--prefix=/usr \
		--sysconfdir=/etc \
		--localstatedir=/var \
		--sbindir=/usr/bin \
		--libexecdir=/usr/lib/$pkgname \
		--disable-static \
		--disable-documentation \
		--with-priv-mode=setuid \
		--with-system-bubblewrap \
		--with-system-helper-user=flatpak

	make
}

check() {
	make -k check
}

package() {
	make DESTDIR="$pkgdir" install
}

sha512sums="13348da9975dd4c5d354330919ca5076862d02ceb4e3ea1f5fdfc3af3b4f6cab025821f35d255a1ab773c7bc4adc27a194bd330adf853108ec6c963d597a9296  flatpak-1.4.0.tar.xz
9287ed146bf71665aa436a2c2110cc5edc829a7b4a3e3190947580850fe9ecfd2bb6adb015c692af022d425fb5259390fcdcbd402e8b0d12ee5d2c1a1071ed4f  musl-fixes.patch"