aboutsummaryrefslogblamecommitdiffstats
path: root/community/kdeclarative/APKBUILD
blob: ff03c0be472f1e5c31b7e04aafa2960aa5a149a7 (plain) (tree)
1
2
3
4
5
6
7
8
9


                                                  
             
        
                                                        
                                                                                                         

                                          

















                             
                       
                                                                                            
                                                     

         
                        
                                         


                                             
                           


         
                


                                                                              


           
                                                              
 
                                                                                                                                                                         
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kdeclarative
pkgver=5.78.0
pkgrel=0
pkgdesc="Provides integration of QML and KDE Frameworks"
arch="all !armhf !mips64 !s390x" # armhf blocked by qt5-qtdeclarative and mips64, s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
depends_dev="
	kconfig-dev
	kglobalaccel-dev
	kguiaddons-dev
	ki18n-dev
	kiconthemes-dev
	kio-dev
	kpackage-dev
	kwidgetsaddons-dev
	kwindowsystem-dev
	libepoxy-dev
	qt5-qtdeclarative-dev
	"
makedepends="$depends_dev
	doxygen
	extra-cmake-modules
	qt5-qttools-dev
	"
checkdepends="xvfb-run"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kdeclarative-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"

build() {
	cmake -B build \
		-DCMAKE_BUILD_TYPE=None \
		-DCMAKE_INSTALL_PREFIX=/usr \
		-DCMAKE_INSTALL_LIBDIR=lib \
		-DBUILD_QCH=ON
	cmake --build build
}

check() {
	cd build

	# quickviewsharedengine requires OpenGL
	CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "quickviewsharedengine"
}

package() {
	DESTDIR="$pkgdir" cmake --build build --target install
}
sha512sums="cb98f7041f93c8a21da74a6bcaf463fdd257aa96a5495200c749d60d517817c6d9be2b58e99b0a8e23996861ed9dcd9043da1643062ac94755070fb1d2b13add  kdeclarative-5.78.0.tar.xz"