aboutsummaryrefslogblamecommitdiffstats
path: root/community/polkit-qt-1/APKBUILD
blob: 8b04aa5257f536e96b7aa32064d697d338ae975d (plain) (tree)
1
2
3
4
5
6
7
8
9


                                                  
              
        



                                                     
                                
                                               
                                                                              



                          
                                         











                                             
                                                                                                                                                                         
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=polkit-qt-1
pkgver=0.113.0
pkgrel=1
pkgdesc="Qt wrapper around polkit-1 client libraries"
arch="all"
url="https://www.kde.org"
license="LGPL-2.1-only"
depends_dev="polkit-elogind-dev"
makedepends="$depends_dev cmake qt5-qtbase-dev"
source="http://download.kde.org/stable/polkit-qt-1/polkit-qt-1-$pkgver.tar.xz"
subpackages="$pkgname-dev"

build() {
	cmake \
		-DCMAKE_BUILD_TYPE=None \
		-DCMAKE_INSTALL_PREFIX=/usr \
		-DCMAKE_INSTALL_LIBDIR=lib
	make
}

check() {
	CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}

package() {
	DESTDIR="$pkgdir" make install
}
sha512sums="deea5d75f547eaa0279c664ec9608b65f464db97fd5fdea27437f8ed4ec033de2b9f91d967deacb28bf0a1e54f131f997acb862cc3e1f8dfcb1f6c337e719b38  polkit-qt-1-0.113.0.tar.xz"