aboutsummaryrefslogblamecommitdiffstats
path: root/community/ruby-net-ldap/gemspec.patch
blob: 5af73d43383ef3a6870c1ebb9a6c88bbb2258f80 (plain) (tree)
1
2
3
4
5
6
7
8






                                                                                                                                       
                                      





                                                             



                                                                                    
    
--- a/net-ldap.gemspec
+++ b/net-ldap.gemspec
@@ -20,9 +20,7 @@
 Our roadmap for Net::LDAP 1.0 is to gain full <em>client</em> compliance with
 the most recent LDAP RFCs (4510-4519, plutions of 4520-4532).}
   s.email = ["blackhedd@rubyforge.org", "gemiel@gmail.com", "rory.ocon@gmail.com", "kaspar.schiess@absurd.li", "austin@rubyforge.org"]
-  s.extra_rdoc_files = ["Contributors.rdoc", "Hacking.rdoc", "History.rdoc", "License.rdoc", "README.rdoc"]
-  s.files = Dir["*.rdoc", "lib/**/*"]
-  s.test_files = s.files.grep(%r{^test})
+  s.files = Dir["lib/**/*.rb"]
   s.homepage = %q{http://github.com/ruby-ldap/ruby-net-ldap}
   s.rdoc_options = ["--main", "README.rdoc"]
   s.require_paths = ["lib"]
@@ -33,5 +31,4 @@
   s.add_development_dependency("rake", "~> 12.3.3")
   s.add_development_dependency("rubocop", "~> 0.49.0")
   s.add_development_dependency("test-unit", "~> 3.3")
-  s.add_development_dependency("byebug", "~> 9.0.6") unless RUBY_PLATFORM == "java"
 end