aboutsummaryrefslogblamecommitdiffstats
path: root/community/yarn/remove-support-for-legacy-nodejs.patch
blob: f3c291ea6d1244513def229168a88c1d936e720a (plain) (tree)
1
2
3
4
5
6
7
8



                    
                                        
                                
                                               
                                       





                                                                                                                     

                 






                                                    
--- dist/bin/yarn.js
+++ dist/bin/yarn.js
@@ -13,10 +13,8 @@
 
 if (semver.satisfies(ver, '>=5.0.0')) {
   path = '../lib/cli/index.js';
-} else if (semver.satisfies(ver, '>=4.0.0')) {
-  path = '../lib-legacy/cli/index.js';
 } else {
-  console.log(require('chalk').red('Node version ' + ver + ' is not supported, please use Node.js 4.0 or higher.'));
+  console.log(require('chalk').red('Node version ' + ver + ' is not supported, please use Node.js 5.0 or higher.'));
   process.exit(1);
 }
 
@@ -27,7 +25,7 @@
 
 // ensure cache directory exists
 var mkdirp = require('mkdirp');
-var constants = require('../lib-legacy/constants');
+var constants = require('../lib/constants');
 mkdirp.sync(constants.MODULE_CACHE_DIRECTORY);
 
 // init roadrunner