aboutsummaryrefslogblamecommitdiffstats
path: root/main/rrdtool/lua-install-cmod.patch
blob: 672aea78a06ab3bc63e6fa5089b1712452f64b5a (plain) (tree)
1
2
3
4
5
6
7
8
9
10
11
12
13












                                                                                                                  
--- ./configure.orig
+++ ./configure
@@ -29330,7 +29330,9 @@
 $as_echo "$as_me: WARNING: Setting Lua include and lib flags to defaults in compat-5.1 and lua 5.1 sources" >&2;}
           LUA_CFLAGS="-I/usr/local/include -I/usr/local/include/lua -I/usr/local/include/lua/$lua_vdot"
           LUA_LFLAGS="-L/usr/local/lib -L/usr/local/lib/lua -L/usr/local/lib/lua/$lua_vdot $lua_libs"
-          LUA_INSTALL_CMOD="/usr/local/lib/lua/$lua_vdot"
+	  if test -z "$LUA_INSTALL_CMOD"; then
+            LUA_INSTALL_CMOD="/usr/local/lib/lua/$lua_vdot"
+	  fi
         fi
 
                                 # Check whether --enable-lua-site-install was given.