aboutsummaryrefslogblamecommitdiffstats
path: root/testing/py3-unoconv/APKBUILD
blob: 5d3e13bc47a5793e0e9bdfb3a327d4cbc660461d (plain) (tree)
1
2
3
4
5
6
7
8
9
                                
                   
            
        

                                                                              

                                           
                 
                             




                                                                                           
                                  
 



                      
           
                                          
                       


         
                              


           
                                                               

 


                                                                                                                                                                  
# Contributor: TBK <tbk@jjtc.eu>
pkgname=py3-unoconv
pkgver=0.8.2
pkgrel=2
pkgdesc="Tool to convert between any document format supported by LibreOffice"
url="http://dag.wieers.com/home-made/unoconv/"
# libreoffice is not built on s390x or mips
arch="noarch !s390x !mips !mips64"
license="GPL-2.0"
depends="libreoffice python3"
makedepends="py3-setuptools"
options="!check"
source="unoconv-$pkgver.tar.gz::https://github.com/dagwieers/unoconv/archive/$pkgver.tar.gz
	setup.py CVE-2019-17400.patch"

builddir="$srcdir"/unoconv-$pkgver

# secfixes:
#   0.8.2-r0:
#     - CVE-2019-17400

prepare() {
	cp "$srcdir"/setup.py "$builddir"/
	default_prepare
}

build() {
	python3 setup.py build
}

package() {
	python3 setup.py install --prefix=/usr --root="$pkgdir"
}

sha512sums="cd6a4d06559895c0aebb5fda51ca86928474dd0ca0aa908e81762643186c29cf8436c889eedbb18bc74ed6016414d1aa831cd034614244d5aae677a6b4cdd4c9  unoconv-0.8.2.tar.gz
b4fa76011fb96ba9521bb09d1a5c43dbd457c50bb2c6d66a5bc65928cde1e1d8174e43ad86f8f53755f222127cc5b0084b4564c248ce1fca56f9acfb4c03d86d  setup.py
ab3a9aad6c14190083364c7430a4a0ed3eaad54225ae88ea72b7ee940b80767298152f5fad4a0e17a506c7dbc85733a9910d2ed1a48c4c95bd078f139ec8f54c  CVE-2019-17400.patch"