aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-10-26 13:21:32 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-11-07 16:21:49 +0000
commit155dac8b94faa2db7204d7330872b85dfc8bb3bf (patch)
treecb575e7e71ad3dab7fa24a8570043c1862b35ff5
parenta1f2d9963fe0a3ba8594a8bf24c7160bd8cd42ac (diff)
main/openssl: re-enable DES, RC4 and fix replaces
DES is needed by NTLM (cyrus-sasl) RC4 is needed by freeradius
-rw-r--r--main/openssl/APKBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/main/openssl/APKBUILD b/main/openssl/APKBUILD
index 93b48c8792d..965e8467920 100644
--- a/main/openssl/APKBUILD
+++ b/main/openssl/APKBUILD
@@ -2,11 +2,12 @@
pkgname=openssl
pkgver=1.1.1
_abiver=${pkgver%.*}
-pkgrel=3
+pkgrel=4
pkgdesc="Toolkit for Transport Layer Security (TLS)"
url="https://www.openssl.org"
arch="all"
license="OpenSSL"
+replaces="libressl"
makedepends_build="perl"
makedepends_host="linux-headers"
makedepends="$makedepends_host $makedepends_build"
@@ -48,7 +49,7 @@ build() {
--libdir=lib \
--openssldir=/etc/ssl \
shared no-zlib $_optflags \
- no-async no-comp no-des no-idea no-mdc2 no-rc4 no-rc5 no-ec2m \
+ no-async no-comp no-idea no-mdc2 no-rc5 no-ec2m \
no-sm2 no-sm4 no-ssl2 no-ssl3 no-seed no-psk \
no-weak-ssl-ciphers \
$CPPFLAGS $CFLAGS $LDFLAGS -Wa,--noexecstack
@@ -67,9 +68,15 @@ package() {
rm "$pkgdir"/usr/bin/c_rehash
}
+dev() {
+ default_dev
+ replaces="libressl-dev"
+}
+
_libcrypto() {
pkgdesc="Crypto library from openssl"
-
+ replaces="libressl2.7-libcrypto"
+ mv "$pkgdir"/etc "$subpkgdir"
mkdir -p "$subpkgdir"/lib "$subpkgdir"/usr/lib
for i in "$pkgdir"/usr/lib/libcrypto*; do
mv $i "$subpkgdir"/lib/