aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-20 06:54:55 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-20 10:17:18 +0000
commite7d80b01714e06fbe8ead3bc2319dcfc95870430 (patch)
treebeacd6ca140c2bf174a2022329fbc2028b34102a
parent9066df94b0bc8ccb852d217b15c3f5c3f4d73aed (diff)
main/softhsm: upgrade to 2.6.0
-rw-r--r--main/softhsm/74b06622cdcf4b104349f5803adca9443dce3abb.patch89
-rw-r--r--main/softhsm/APKBUILD41
-rw-r--r--main/softhsm/softhsm-2.5.0-botan_ecb-exception-fix.patch19
3 files changed, 17 insertions, 132 deletions
diff --git a/main/softhsm/74b06622cdcf4b104349f5803adca9443dce3abb.patch b/main/softhsm/74b06622cdcf4b104349f5803adca9443dce3abb.patch
deleted file mode 100644
index 96c44de4987..00000000000
--- a/main/softhsm/74b06622cdcf4b104349f5803adca9443dce3abb.patch
+++ /dev/null
@@ -1,89 +0,0 @@
-From e69657101cb219820d7d94d2df4e08815f83d28b Mon Sep 17 00:00:00 2001
-From: Peter Wu <peter@lekensteyn.nl>
-Date: Wed, 12 Dec 2018 21:47:23 +0100
-Subject: [PATCH] Issue #435: Fix botan build without EDDSA
-
-Loading libsofthsm2.so (built on Ubuntu 14.04 with botan) failed with:
-
- ERROR: Could not load the PKCS#11 library/module: src/lib/libsofthsm2.so: undefined symbol: _ZN17BotanEDPrivateKeyD1Ev
-
-Fixes #435 (a regression in 2.5.0 due to commit 2751555).
----
- src/lib/crypto/BotanEDKeyPair.cpp | 2 ++
- src/lib/crypto/BotanEDKeyPair.h | 2 ++
- src/lib/crypto/BotanEDPrivateKey.h | 2 ++
- src/lib/crypto/BotanEDPublicKey.h | 2 ++
- 4 files changed, 8 insertions(+)
-
-diff --git a/src/lib/crypto/BotanEDKeyPair.cpp b/src/lib/crypto/BotanEDKeyPair.cpp
-index 3be3fa5e..3e967e55 100644
---- a/src/lib/crypto/BotanEDKeyPair.cpp
-+++ b/src/lib/crypto/BotanEDKeyPair.cpp
-@@ -31,6 +31,7 @@
- *****************************************************************************/
-
- #include "config.h"
-+#ifdef WITH_EDDSA
- #include "log.h"
- #include "BotanEDKeyPair.h"
-
-@@ -67,3 +68,4 @@ const PrivateKey* BotanEDKeyPair::getConstPrivateKey() const
- {
- return &privKey;
- }
-+#endif
-diff --git a/src/lib/crypto/BotanEDKeyPair.h b/src/lib/crypto/BotanEDKeyPair.h
-index 02d6a4c5..4f2cffee 100644
---- a/src/lib/crypto/BotanEDKeyPair.h
-+++ b/src/lib/crypto/BotanEDKeyPair.h
-@@ -34,6 +34,7 @@
- #define _SOFTHSM_V2_BOTANEDKEYPAIR_H
-
- #include "config.h"
-+#ifdef WITH_EDDSA
- #include "AsymmetricKeyPair.h"
- #include "BotanEDPublicKey.h"
- #include "BotanEDPrivateKey.h"
-@@ -62,5 +63,6 @@ class BotanEDKeyPair : public AsymmetricKeyPair
- // The private key
- BotanEDPrivateKey privKey;
- };
-+#endif
- #endif // !_SOFTHSM_V2_BOTANEDKEYPAIR_H
-
-diff --git a/src/lib/crypto/BotanEDPrivateKey.h b/src/lib/crypto/BotanEDPrivateKey.h
-index d71f6c07..ac236bb8 100644
---- a/src/lib/crypto/BotanEDPrivateKey.h
-+++ b/src/lib/crypto/BotanEDPrivateKey.h
-@@ -34,6 +34,7 @@
- #define _SOFTHSM_V2_BOTANEDPRIVATEKEY_H
-
- #include "config.h"
-+#ifdef WITH_EDDSA
- #include "EDPrivateKey.h"
- #include <botan/pk_keys.h>
-
-@@ -82,4 +83,5 @@ class BotanEDPrivateKey : public EDPrivateKey
- // Create the Botan representation of the key
- void createBotanKey();
- };
-+#endif
- #endif // !_SOFTHSM_V2_BOTANEDPRIVATEKEY_H
-diff --git a/src/lib/crypto/BotanEDPublicKey.h b/src/lib/crypto/BotanEDPublicKey.h
-index fce34a5f..15e6d458 100644
---- a/src/lib/crypto/BotanEDPublicKey.h
-+++ b/src/lib/crypto/BotanEDPublicKey.h
-@@ -34,6 +34,7 @@
- #define _SOFTHSM_V2_BOTANEDPUBLICKEY_H
-
- #include "config.h"
-+#ifdef WITH_EDDSA
- #include "EDPublicKey.h"
- #include <botan/pk_keys.h>
-
-@@ -74,4 +75,5 @@ class BotanEDPublicKey : public EDPublicKey
- // Create the Botan representation of the key
- void createBotanKey();
- };
-+#endif
- #endif // !_SOFTHSM_V2_BOTANEDPUBLICKEY_H
diff --git a/main/softhsm/APKBUILD b/main/softhsm/APKBUILD
index ef46d1b00f5..6c3d6adcd7a 100644
--- a/main/softhsm/APKBUILD
+++ b/main/softhsm/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Frank Felhoffer <silveraid@hackme.ca>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=softhsm
-pkgver=2.5.0
-pkgrel=4
+pkgver=2.6.0
+pkgrel=0
pkgdesc="cryptographic store accessible through a PKCS #11"
url="https://www.opendnssec.org/softhsm/"
arch="all"
@@ -10,36 +10,29 @@ license="BSD-2-Clause"
depends="sqlite"
checkdepends="cppunit-dev"
makedepends="autoconf automake botan-dev libtool p11-kit-dev sqlite-dev"
-install=""
subpackages="$pkgname-doc"
-source="https://dist.opendnssec.org/source/$pkgname-$pkgver.tar.gz
- 74b06622cdcf4b104349f5803adca9443dce3abb.patch
- softhsm-2.5.0-botan_ecb-exception-fix.patch
- "
-builddir="$srcdir/$pkgname-$pkgver"
+source="https://dist.opendnssec.org/source/softhsm-$pkgver.tar.gz
+ "
build() {
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --with-crypto-backend=botan \
- --with-botan=/usr \
- --with-sqlite3=/usr \
- --with-objectstore-backend-db
-
- make
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --with-crypto-backend=botan \
+ --with-botan=/usr \
+ --with-sqlite3=/usr \
+ --with-objectstore-backend-db
+ make
}
check() {
- make check
- ldd src/lib/.libs/libsofthsm2.so
+ make check
+ ldd src/lib/.libs/libsofthsm2.so
}
package() {
- make -j1 DESTDIR="$pkgdir/" install
+ make -j1 DESTDIR="$pkgdir/" install
}
-sha512sums="a1e686729196dc25591eb3da57c2c8ea8494ed274ba711842b2dcae696f477a202acda13a975b8fb1eb68e8e44a79e839dbbc6ba500cab02ad13072c660752d9 softhsm-2.5.0.tar.gz
-08d10a980d66e8b5f5853b460065098c2a2cdcd9f36b9e0971456030e8bd9be424de249ff79b4f7cd53f4b0e4b18053096eb405d31c6a346387e695021ce2eff 74b06622cdcf4b104349f5803adca9443dce3abb.patch
-25dc68c404f89936df1d7fcdf5460b8f42fff66f4a76d0e50f139337cb515fac853aa76b0b276cdb9186f2cd78a4099fcfa469629c1531dfa4023fa19c23823b softhsm-2.5.0-botan_ecb-exception-fix.patch"
+sha512sums="9d70fd05817a9ea4b0c8acad5f9f2a33ce38115414e84e5f43ec433a6f07440ea29c3b81ae5150ee7f324080c4603951406fa22052f4b6dbcc0c4e5cfd3e1723 softhsm-2.6.0.tar.gz"
diff --git a/main/softhsm/softhsm-2.5.0-botan_ecb-exception-fix.patch b/main/softhsm/softhsm-2.5.0-botan_ecb-exception-fix.patch
deleted file mode 100644
index a71081e0eed..00000000000
--- a/main/softhsm/softhsm-2.5.0-botan_ecb-exception-fix.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-commit a9a40fc64635cfb924279cae3c42e6946e89718c
-Author: tcely <tcely@users.noreply.github.com>
-Date: Wed Mar 6 07:14:32 2019 -0500
-
- fix protected Exception usage
-
-diff --git a/src/lib/crypto/Botan_ecb.cpp b/src/lib/crypto/Botan_ecb.cpp
-index f27276e..6947aab 100644
---- a/src/lib/crypto/Botan_ecb.cpp
-+++ b/src/lib/crypto/Botan_ecb.cpp
-@@ -108,7 +108,7 @@ void ECB_Encryption::finish(secure_vector<byte>& buffer, size_t offset)
- padding().add_padding(buffer, bytes_in_final_block, BS);
-
- if(buffer.size() % BS)
-- throw Exception("Did not pad to full block size in " + name());
-+ throw Invalid_State("Did not pad to full block size in " + name());
-
- update(buffer, offset);
- }