aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-06-17 14:28:13 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-06-17 14:23:18 +0200
commitf49ce14f0bbc45d0913d83b7015e13f880146f92 (patch)
treee355cec03155f0c2092644afc6058e05286495bb
parent824bb08c5d3e74eb9d15b2585db76b6ad6d157f1 (diff)
community/ruby-nokogiri: fix tests and enable check
-rw-r--r--community/ruby-nokogiri/APKBUILD8
-rw-r--r--community/ruby-nokogiri/skip-tests-broken-on-musl.patch10
2 files changed, 15 insertions, 3 deletions
diff --git a/community/ruby-nokogiri/APKBUILD b/community/ruby-nokogiri/APKBUILD
index 65ac7c920c3..92df53a1e8f 100644
--- a/community/ruby-nokogiri/APKBUILD
+++ b/community/ruby-nokogiri/APKBUILD
@@ -12,9 +12,10 @@ depends="ruby ruby-mini_portile2"
makedepends="ruby-dev libxml2-dev libxslt-dev"
checkdepends="ruby-minitest"
source="https://rubygems.org/downloads/$_gemname-$pkgver.gem
- fix-extconf.patch"
+ fix-extconf.patch
+ skip-tests-broken-on-musl.patch
+ "
builddir="$srcdir/$_gemname-$pkgver"
-options="!check" # FIXME: some tests fails due to encoding issues
unpack() {
default_unpack
@@ -80,4 +81,5 @@ package() {
}
sha512sums="4825cc19667393c41a0c5a662474556991da3955fb17e67a363f979da8fadf0680eb4f89a7c87b71f6deba9db64e67bd463d5562d58604ea71a168abb8215eed nokogiri-1.8.3.gem
-514cc33109357457dfd7739991f3d270fe62a26313a5dfed0f539e89e4ed8de7dd08744540c7becc93ad12e6d096f2c4b4c3fb15f47b827a65352b895ab62a89 fix-extconf.patch"
+514cc33109357457dfd7739991f3d270fe62a26313a5dfed0f539e89e4ed8de7dd08744540c7becc93ad12e6d096f2c4b4c3fb15f47b827a65352b895ab62a89 fix-extconf.patch
+5f92d4cf87751c404a33dfbdc035dd5b54163eccdc46b4f515e6d6367a9573cf3fc4ef3c12c5b9e099b20f6c563d5a573acb1c2716890e492bfb26aa91f2cb5d skip-tests-broken-on-musl.patch"
diff --git a/community/ruby-nokogiri/skip-tests-broken-on-musl.patch b/community/ruby-nokogiri/skip-tests-broken-on-musl.patch
new file mode 100644
index 00000000000..f07717a98a4
--- /dev/null
+++ b/community/ruby-nokogiri/skip-tests-broken-on-musl.patch
@@ -0,0 +1,10 @@
+--- a/test/html/test_document_encoding.rb
++++ b/test/html/test_document_encoding.rb
+@@ -19,6 +19,7 @@
+ end
+
+ def test_encoding_without_charset
++ skip 'Not supported on musl'
+ doc = Nokogiri::HTML File.open(SHIFT_JIS_NO_CHARSET, 'r:cp932:cp932').read
+
+ hello = "こんにちは"