aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosef Fröhle <github@josef-froehle.de>2018-12-29 14:44:52 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-12-31 14:44:45 +0000
commit8bdc689c2b5ad9fd53e4f301dcb18bf37e336421 (patch)
tree30153dbe1fac3b4411cce10c644c6fd26257d607
parenta48553e706244b88d2af557f8b0cf9917c72c22d (diff)
main/libspf2: remove not need libreplace from source
-rw-r--r--main/libspf2/00001.patch72
-rw-r--r--main/libspf2/00002.patch227
-rw-r--r--main/libspf2/0001-provide-dn_skipname.patch120
-rw-r--r--main/libspf2/APKBUILD26
-rw-r--r--main/libspf2/libspf2-libreplace-fix.patch61
5 files changed, 307 insertions, 199 deletions
diff --git a/main/libspf2/00001.patch b/main/libspf2/00001.patch
new file mode 100644
index 00000000000..f745121000c
--- /dev/null
+++ b/main/libspf2/00001.patch
@@ -0,0 +1,72 @@
+--- a/src/libspf2/spf_compile.c
++++ b/src/libspf2/spf_compile.c
+@@ -577,7 +577,7 @@ SPF_c_parse_macro(SPF_server_t *spf_serv
+ switch (src[idx]) {
+ case '%':
+ if (spf_server->debug > 3)
+- SPF_debugf("Adding literal %%");
++ SPF_debugf("%s", "Adding literal %%");
+ SPF_ENSURE_STRING_AVAIL(1);
+ *dst++ = '%';
+ ds_len++;
+@@ -586,7 +586,7 @@ SPF_c_parse_macro(SPF_server_t *spf_serv
+
+ case '_':
+ if (spf_server->debug > 3)
+- SPF_debugf("Adding literal space");
++ SPF_debugf("%s", "Adding literal space");
+ SPF_ENSURE_STRING_AVAIL(1);
+ *dst++ = ' ';
+ ds_len++;
+@@ -595,7 +595,7 @@ SPF_c_parse_macro(SPF_server_t *spf_serv
+
+ case '-':
+ if (spf_server->debug > 3)
+- SPF_debugf("Adding escaped space");
++ SPF_debugf("%s", "Adding escaped space");
+ SPF_ENSURE_STRING_AVAIL(3);
+ *dst++ = '%'; *dst++ = '2'; *dst++ = '0';
+ ds_len += 3;
+--- a/src/libspf2/spf_dns.c
++++ b/src/libspf2/spf_dns.c
+@@ -105,7 +105,7 @@ SPF_dns_debug_post(SPF_dns_server_t *spf
+ break;
+
+ default:
+- SPF_debugf(" - Unknown RR type");
++ SPF_debugf("%s", " - Unknown RR type");
+ break;
+ }
+ }
+--- a/src/libspf2/spf_dns_zone.c
++++ b/src/libspf2/spf_dns_zone.c
+@@ -114,7 +114,7 @@ SPF_dns_zone_find(SPF_dns_server_t *spf_
+ return spfhook->zone[i];
+ }
+ if (spf_dns_server->debug)
+- SPF_debugf("zone: Exact not found");
++ SPF_debugf("%s", "zone: Exact not found");
+ }
+ else {
+ /* We are looking up a record, so lookup-matching semantics apply. */
+@@ -152,7 +152,7 @@ SPF_dns_zone_find(SPF_dns_server_t *spf_
+ }
+ }
+ if (spf_dns_server->debug)
+- SPF_debugf("zone: Non-exact not found");
++ SPF_debugf("%s", "zone: Non-exact not found");
+ }
+
+ return NULL;
+--- a/src/libspf2/spf_id2str.c
++++ b/src/libspf2/spf_id2str.c
+@@ -52,7 +52,7 @@ SPF_record_stringify_data(SPF_data_t *da
+ SPF_data_t *cidr_data;
+
+ if (debug)
+- SPF_debugf(" string data: Building");
++ SPF_debugf("%s", " string data: Building");
+
+ if (p_end - p <= 0)
+ return SPF_E_INTERNAL_ERROR;
+
diff --git a/main/libspf2/00002.patch b/main/libspf2/00002.patch
new file mode 100644
index 00000000000..aba70e4aa10
--- /dev/null
+++ b/main/libspf2/00002.patch
@@ -0,0 +1,227 @@
+libreplace is not needed on Linux
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -273,8 +273,6 @@ AC_CHECK_FUNCS([strchr strcspn strdup st
+ AC_CHECK_FUNCS([strcasecmp strncasecmp strspn strtoul])
+ AC_CHECK_FUNCS([gethostbyname inet_ntoa select strrchr strstr strtol])
+
+-AC_REPLACE_FUNCS([getopt_long_only strncasecmp])
+-AC_REPLACE_FUNCS([__ns_initparse __ns_name_uncompress __ns_msg_getflag])
+ dnl Magnus Holmgren says this avoids linking a private function
+ AC_LIBOBJ([__ns_get16])
+
+@@ -282,7 +280,6 @@ AC_CONFIG_FILES([Makefile
+ Doxyfile
+ src/Makefile
+ src/include/Makefile
+- src/libreplace/Makefile
+ src/libspf2/Makefile
+ src/spfquery/Makefile
+ src/spftest/Makefile
+--- a/src/libspf2/Makefile.am
++++ b/src/libspf2/Makefile.am
+@@ -34,10 +34,6 @@ libspf2_la_SOURCES = \
+ spf_utils.c \
+ spf_win32.c
+
+-libspf2_la_LIBADD = $(top_builddir)/src/libreplace/libreplace.la
+-
+-
+-
+ libspf2_la_LDFLAGS = -version-info 3:0:1
+
+ # Copied from the libtool info file:
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -4,5 +4,5 @@ AUTOMAKE_OPTIONS = foreign
+ # Attempt to disable parallel processing.
+ .NOTPARALLEL:
+ .NO_PARALLEL:
+-SUBDIRS = include libreplace libspf2 spfquery spftest spfd spf_example
++SUBDIRS = include libspf2 spfquery spftest spfd spf_example
+ TARGETS =
+--- a/aclocal.m4
++++ b/aclocal.m4
+@@ -1,4 +1,5 @@
+ # generated automatically by aclocal 1.11.1 -*- Autoconf -*-
++# and touched to get build order right
+
+ # Copyright (C) 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004,
+ # 2005, 2006, 2007, 2008, 2009 Free Software Foundation, Inc.
+--- a/configure
++++ b/configure
+@@ -13602,73 +13602,6 @@ fi
+ done
+
+
+-ac_fn_c_check_func "$LINENO" "getopt_long_only" "ac_cv_func_getopt_long_only"
+-if test "x$ac_cv_func_getopt_long_only" = xyes; then :
+- $as_echo "#define HAVE_GETOPT_LONG_ONLY 1" >>confdefs.h
+-
+-else
+- case " $LIBOBJS " in
+- *" getopt_long_only.$ac_objext "* ) ;;
+- *) LIBOBJS="$LIBOBJS getopt_long_only.$ac_objext"
+- ;;
+-esac
+-
+-fi
+-
+-ac_fn_c_check_func "$LINENO" "strncasecmp" "ac_cv_func_strncasecmp"
+-if test "x$ac_cv_func_strncasecmp" = xyes; then :
+- $as_echo "#define HAVE_STRNCASECMP 1" >>confdefs.h
+-
+-else
+- case " $LIBOBJS " in
+- *" strncasecmp.$ac_objext "* ) ;;
+- *) LIBOBJS="$LIBOBJS strncasecmp.$ac_objext"
+- ;;
+-esac
+-
+-fi
+-
+-
+-ac_fn_c_check_func "$LINENO" "__ns_initparse" "ac_cv_func___ns_initparse"
+-if test "x$ac_cv_func___ns_initparse" = xyes; then :
+- $as_echo "#define HAVE___NS_INITPARSE 1" >>confdefs.h
+-
+-else
+- case " $LIBOBJS " in
+- *" __ns_initparse.$ac_objext "* ) ;;
+- *) LIBOBJS="$LIBOBJS __ns_initparse.$ac_objext"
+- ;;
+-esac
+-
+-fi
+-
+-ac_fn_c_check_func "$LINENO" "__ns_name_uncompress" "ac_cv_func___ns_name_uncompress"
+-if test "x$ac_cv_func___ns_name_uncompress" = xyes; then :
+- $as_echo "#define HAVE___NS_NAME_UNCOMPRESS 1" >>confdefs.h
+-
+-else
+- case " $LIBOBJS " in
+- *" __ns_name_uncompress.$ac_objext "* ) ;;
+- *) LIBOBJS="$LIBOBJS __ns_name_uncompress.$ac_objext"
+- ;;
+-esac
+-
+-fi
+-
+-ac_fn_c_check_func "$LINENO" "__ns_msg_getflag" "ac_cv_func___ns_msg_getflag"
+-if test "x$ac_cv_func___ns_msg_getflag" = xyes; then :
+- $as_echo "#define HAVE___NS_MSG_GETFLAG 1" >>confdefs.h
+-
+-else
+- case " $LIBOBJS " in
+- *" __ns_msg_getflag.$ac_objext "* ) ;;
+- *) LIBOBJS="$LIBOBJS __ns_msg_getflag.$ac_objext"
+- ;;
+-esac
+-
+-fi
+-
+-
+ case " $LIBOBJS " in
+ *" __ns_get16.$ac_objext "* ) ;;
+ *) LIBOBJS="$LIBOBJS __ns_get16.$ac_objext"
+@@ -13676,7 +13609,7 @@ case " $LIBOBJS " in
+ esac
+
+
+-ac_config_files="$ac_config_files Makefile Doxyfile src/Makefile src/include/Makefile src/libreplace/Makefile src/libspf2/Makefile src/spfquery/Makefile src/spftest/Makefile src/spfd/Makefile src/spf_example/Makefile"
++ac_config_files="$ac_config_files Makefile Doxyfile src/Makefile src/include/Makefile src/libspf2/Makefile src/spfquery/Makefile src/spftest/Makefile src/spfd/Makefile src/spf_example/Makefile"
+
+ cat >confcache <<\_ACEOF
+ # This file is a shell script that caches the results of configure
+@@ -14693,7 +14626,6 @@ do
+ "Doxyfile") CONFIG_FILES="$CONFIG_FILES Doxyfile" ;;
+ "src/Makefile") CONFIG_FILES="$CONFIG_FILES src/Makefile" ;;
+ "src/include/Makefile") CONFIG_FILES="$CONFIG_FILES src/include/Makefile" ;;
+- "src/libreplace/Makefile") CONFIG_FILES="$CONFIG_FILES src/libreplace/Makefile" ;;
+ "src/libspf2/Makefile") CONFIG_FILES="$CONFIG_FILES src/libspf2/Makefile" ;;
+ "src/spfquery/Makefile") CONFIG_FILES="$CONFIG_FILES src/spfquery/Makefile" ;;
+ "src/spftest/Makefile") CONFIG_FILES="$CONFIG_FILES src/spftest/Makefile" ;;
+--- a/config.h.in
++++ b/config.h.in
+@@ -49,9 +49,6 @@
+ /* Define to 1 if you have the <getopt.h> header file. */
+ #undef HAVE_GETOPT_H
+
+-/* Define to 1 if you have the `getopt_long_only' function. */
+-#undef HAVE_GETOPT_LONG_ONLY
+-
+ /* Define to 1 if you have the <grp.h> header file. */
+ #undef HAVE_GRP_H
+
+--- a/src/libspf2/Makefile.in
++++ b/src/libspf2/Makefile.in
+@@ -69,8 +69,7 @@ am__base_list = \
+ sed '$$!N;$$!N;$$!N;$$!N;s/\n/ /g'
+ am__installdirs = "$(DESTDIR)$(libdir)"
+ LTLIBRARIES = $(lib_LTLIBRARIES)
+-libspf2_la_DEPENDENCIES = \
+- $(top_builddir)/src/libreplace/libreplace.la
++libspf2_la_LIBADD =
+ am_libspf2_la_OBJECTS = spf_compile.lo spf_dns.lo spf_dns_cache.lo \
+ spf_dns_null.lo spf_dns_resolv.lo spf_dns_rr.lo \
+ spf_dns_test.lo spf_dns_windns.lo spf_dns_zone.lo \
+@@ -289,7 +288,6 @@ libspf2_la_SOURCES = \
+ spf_utils.c \
+ spf_win32.c
+
+-libspf2_la_LIBADD = $(top_builddir)/src/libreplace/libreplace.la
+ libspf2_la_LDFLAGS = -version-info 3:0:1
+ all: all-recursive
+
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -151,7 +151,7 @@ SED = @SED@
+ SET_MAKE = @SET_MAKE@
+ SHELL = @SHELL@
+ STRIP = @STRIP@
+-SUBDIRS = include libreplace libspf2 spfquery spftest spfd spf_example
++SUBDIRS = include libspf2 spfquery spftest spfd spf_example
+ VERSION = @VERSION@
+ abs_builddir = @abs_builddir@
+ abs_srcdir = @abs_srcdir@
+--- a/src/spfd/spfd.c
++++ b/src/spfd/spfd.c
+@@ -88,12 +88,8 @@
+ #include <grp.h>
+ #endif
+
+-#ifdef HAVE_GETOPT_LONG_ONLY
+ #define _GNU_SOURCE
+ #include <getopt.h>
+-#else
+-#include "libreplace/getopt.h"
+-#endif
+
+ #include <unistd.h>
+ #include <netdb.h>
+--- a/src/spfquery/spfquery.c
++++ b/src/spfquery/spfquery.c
+@@ -46,8 +46,6 @@
+
+ #define SPF_TEST_VERSION "3.0"
+
+-#include "libreplace/win32_config.h"
+-
+ #ifdef HAVE_CONFIG_H
+ # include "config.h"
+ #endif
+@@ -88,12 +86,8 @@
+ # include <arpa/inet.h> /* in_addr struct */
+ #endif
+
+-#ifdef HAVE_GETOPT_LONG_ONLY
+ #define _GNU_SOURCE
+ #include <getopt.h>
+-#else
+-#include "libreplace/getopt.h"
+-#endif
+
+ #ifdef _WIN32
+ #include "spf_win32.h"
+
diff --git a/main/libspf2/0001-provide-dn_skipname.patch b/main/libspf2/0001-provide-dn_skipname.patch
deleted file mode 100644
index e53001f7931..00000000000
--- a/main/libspf2/0001-provide-dn_skipname.patch
+++ /dev/null
@@ -1,120 +0,0 @@
-From 808b584d22106828aaaa3f2a52b1d076b6e66040 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Thu, 11 Sep 2014 08:09:34 +0000
-Subject: [PATCH] provide dn_skipname
-
----
- configure.ac | 2 +-
- src/libreplace/__dn_skipname.c | 87 ++++++++++++++++++++++++++++++++++++++++++
- 2 files changed, 88 insertions(+), 1 deletion(-)
- create mode 100644 src/libreplace/__dn_skipname.c
-
-diff --git a/configure.ac b/configure.ac
-index 63e398c..739da3b 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -274,7 +274,7 @@ AC_CHECK_FUNCS([strcasecmp strncasecmp strspn strtoul])
- AC_CHECK_FUNCS([gethostbyname inet_ntoa select strrchr strstr strtol])
-
- AC_REPLACE_FUNCS([getopt_long_only strncasecmp])
--AC_REPLACE_FUNCS([__ns_initparse __ns_name_uncompress __ns_msg_getflag])
-+AC_REPLACE_FUNCS([__ns_initparse __ns_name_uncompress __ns_msg_getflag __dn_skipname])
- dnl Magnus Holmgren says this avoids linking a private function
- AC_LIBOBJ([__ns_get16])
-
-diff --git a/src/libreplace/__dn_skipname.c b/src/libreplace/__dn_skipname.c
-new file mode 100644
-index 0000000..88d48b5
---- /dev/null
-+++ b/src/libreplace/__dn_skipname.c
-@@ -0,0 +1,87 @@
-+/* taken from OpenBSD source */
-+/*
-+ * ++Copyright++ 1985, 1993
-+ * -
-+ * Copyright (c) 1985, 1993
-+ * The Regents of the University of California. All rights reserved.
-+ *
-+ * Redistribution and use in source and binary forms, with or without
-+ * modification, are permitted provided that the following conditions
-+ * are met:
-+ * 1. Redistributions of source code must retain the above copyright
-+ * notice, this list of conditions and the following disclaimer.
-+ * 2. Redistributions in binary form must reproduce the above copyright
-+ * notice, this list of conditions and the following disclaimer in the
-+ * documentation and/or other materials provided with the distribution.
-+ * 3. Neither the name of the University nor the names of its contributors
-+ * may be used to endorse or promote products derived from this software
-+ * without specific prior written permission.
-+ *
-+ * THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
-+ * ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
-+ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
-+ * ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE
-+ * FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
-+ * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
-+ * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
-+ * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
-+ * LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
-+ * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
-+ * SUCH DAMAGE.
-+ * -
-+ * Portions Copyright (c) 1993 by Digital Equipment Corporation.
-+ *
-+ * Permission to use, copy, modify, and distribute this software for any
-+ * purpose with or without fee is hereby granted, provided that the above
-+ * copyright notice and this permission notice appear in all copies, and that
-+ * the name of Digital Equipment Corporation not be used in advertising or
-+ * publicity pertaining to distribution of the document or software without
-+ * specific, written prior permission.
-+ *
-+ * THE SOFTWARE IS PROVIDED "AS IS" AND DIGITAL EQUIPMENT CORP. DISCLAIMS ALL
-+ * WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES
-+ * OF MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL DIGITAL EQUIPMENT
-+ * CORPORATION BE LIABLE FOR ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL
-+ * DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR
-+ * PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS
-+ * ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS
-+ * SOFTWARE.
-+ * -
-+ * --Copyright--
-+ */
-+
-+/*
-+ * Skip over a compressed domain name. Return the size or -1.
-+ */
-+#include <sys/types.h>
-+#include <resolv.h>
-+
-+int
-+__dn_skipname(const u_char *comp_dn, const u_char *eom)
-+{
-+ const u_char *cp;
-+ int n;
-+
-+ cp = comp_dn;
-+ while (cp < eom && (n = *cp++)) {
-+ /*
-+ * check for indirection
-+ */
-+ switch (n & INDIR_MASK) {
-+ case 0: /* normal case, n == len */
-+ cp += n;
-+ continue;
-+ case INDIR_MASK: /* indirection */
-+ cp++;
-+ break;
-+ default: /* illegal type */
-+ return (-1);
-+ }
-+ break;
-+ }
-+ if (cp > eom)
-+ return (-1);
-+ return (cp - comp_dn);
-+}
-+
-+
---
-2.1.0
-
diff --git a/main/libspf2/APKBUILD b/main/libspf2/APKBUILD
index 27855d6d87a..7d10c7e0bc9 100644
--- a/main/libspf2/APKBUILD
+++ b/main/libspf2/APKBUILD
@@ -1,8 +1,9 @@
-#Contributor: Valery Kartel <valery.kartel@gmail.com>
+# Contributor: Valery Kartel <valery.kartel@gmail.com>
+# Contributor: Josef Fröhle <github@josef-froehle.de>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libspf2
pkgver=1.2.10
-pkgrel=2
+pkgrel=3
pkgdesc="Sender Policy Framework library, a part of the SPF/SRS protocol pair."
url="http://www.libspf2.org"
arch="all"
@@ -11,8 +12,8 @@ subpackages="$pkgname-dev $pkgname-tools"
makedepends="autoconf automake libtool"
depends=
source="http://www.libspf2.org/spf/$pkgname-$pkgver.tar.gz
- 0001-provide-dn_skipname.patch
- libspf2-libreplace-fix.patch
+ 00001.patch
+ 00002.patch
netdb_success.patch
musl-res_close.patch
fix-gcc-variadic-macros.patch
@@ -22,6 +23,7 @@ _builddir="$srcdir"/$pkgname-$pkgver
prepare() {
cd "$_builddir"
update_config_sub || return 1
+ rm -r src/libreplace
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
@@ -54,21 +56,9 @@ tools() {
rm -fr "$pkgdir"/usr/bin
}
-md5sums="7bb9937d0705649eaa8646de66dc3562 libspf2-1.2.10.tar.gz
-24b77cb74901d56de89b24ef10b46b85 0001-provide-dn_skipname.patch
-6dd2d5f33c5f1a5b7c14eec4c71767cd libspf2-libreplace-fix.patch
-e364ae123e18ec330339824e71774b44 netdb_success.patch
-984f356b97d936395ee061d6c6003d0a musl-res_close.patch
-6b3c05768fe5adb2cc65fb8d5c0a42c2 fix-gcc-variadic-macros.patch"
-sha256sums="d91e3de81ae287a2976c44f60283bd3000d720e6a112dc7142eedf1831b821c9 libspf2-1.2.10.tar.gz
-b6038c035c08e31a5407ed06d4af490aea357c1e51c218a02c703a9eace9a072 0001-provide-dn_skipname.patch
-f9ee6d10be25a52d2432ac62114c37e2dd4c00c8e11d908f2f2ed0d4ba71b139 libspf2-libreplace-fix.patch
-381d3cb2ef4257eb93dc52b39944948705feaf29223fa263af9c362963eb136e netdb_success.patch
-8d7392aaf3db6f32c96c3f3dac6d928762e0149d966e98fbedc434308894e03b musl-res_close.patch
-96ce1bb636942923ef17505dd42b9de8b8cd4d817f84a315c8053c263725c5ec fix-gcc-variadic-macros.patch"
sha512sums="162ce382628c6fcadac3e11f5a12442db622bb23f7ec503e16f5ba7fc88afdd777bce6b093c12a58210355985fd11b74b140f08fab347334d82d953dd183b130 libspf2-1.2.10.tar.gz
-cc8c77963a3bc0c54442c81146cc27e482c43787586ab8885e3fe0fd2cfcba089f5a5cfeda4c3307fe5cc36ac8768f748d9a8467e9b8ca41e9ad157b61bbce49 0001-provide-dn_skipname.patch
-226e1d7a1d381f35206aaecafb33955a6ecd08c8c18f4d6fe443e359f0139aeeb314012296a53e7c017d68373f4e1fa27010514296f15ab86f059e531866b95a libspf2-libreplace-fix.patch
+3b9bff9b5a5b95f6722f86a43373b0c84cbb79a4509cf0c73486612c0a1b33587bb0b42966b0d2e3a317e4d7a730091fa444bd1258afd06bb3553c4a96d3ee34 00001.patch
+18ddfe106b652e2fb9e36a9f1743fc7cecf38530da65a06ac892b60d2c430aaad657f5653495950d4af4b9833826366b79e629937498e5ce7f6af716303221c4 00002.patch
033dd1e959004f7a1026fb1de73813e934560101e04897297e468918ee28e4d7d0f271d6f05d984db22dd43e097f6aa133df18d11419b085d89db89b120750c9 netdb_success.patch
4fb8a28a667d8fe54a48fa89230446b758c6d532866ee26e8b9ef3032f6e0993ec19a2cc2fb265d18d259e35de6fe66183763bbc69c424de70ad8fe0dbcf7a2f musl-res_close.patch
2face288cfb2cbcfced0f6d47f905b9efdccf696de780892c4e36b134bb4dbe77416b42f42f8ccb16da47551d800fe037899324dec33e140fb8cea0f201abd74 fix-gcc-variadic-macros.patch"
diff --git a/main/libspf2/libspf2-libreplace-fix.patch b/main/libspf2/libspf2-libreplace-fix.patch
deleted file mode 100644
index 4f7c63a2fe8..00000000000
--- a/main/libspf2/libspf2-libreplace-fix.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-diff --git a/src/libreplace/__ns_initparse.c b/src/libreplace/__ns_initparse.c
-index 10a7c9c..f22fa09 100644
---- a/src/libreplace/__ns_initparse.c
-+++ b/src/libreplace/__ns_initparse.c
-@@ -52,26 +52,6 @@ static void setsection(ns_msg *msg, ns_sect sect);
-
- /* Public. */
-
--/* These need to be in the same order as the nres.h:ns_flag enum. */
--struct _ns_flagdata _ns_flagdata[16] = {
-- { 0x8000, 15 }, /* qr. */
-- { 0x7800, 11 }, /* opcode. */
-- { 0x0400, 10 }, /* aa. */
-- { 0x0200, 9 }, /* tc. */
-- { 0x0100, 8 }, /* rd. */
-- { 0x0080, 7 }, /* ra. */
-- { 0x0040, 6 }, /* z. */
-- { 0x0020, 5 }, /* ad. */
-- { 0x0010, 4 }, /* cd. */
-- { 0x000f, 0 }, /* rcode. */
-- { 0x0000, 0 }, /* expansion (1/6). */
-- { 0x0000, 0 }, /* expansion (2/6). */
-- { 0x0000, 0 }, /* expansion (3/6). */
-- { 0x0000, 0 }, /* expansion (4/6). */
-- { 0x0000, 0 }, /* expansion (5/6). */
-- { 0x0000, 0 }, /* expansion (6/6). */
--};
--
- int
- ns_skiprr(const u_char *ptr, const u_char *eom, ns_sect section, int count) {
- const u_char *optr = ptr;
-diff --git a/src/libreplace/__ns_msg_getflag.c b/src/libreplace/__ns_msg_getflag.c
-index 19bfb88..a46c017 100644
---- a/src/libreplace/__ns_msg_getflag.c
-+++ b/src/libreplace/__ns_msg_getflag.c
-@@ -11,6 +11,25 @@
- #include "arpa_nameser.h"
-
-
-+/* These need to be in the same order as the nres.h:ns_flag enum. */
-+struct _ns_flagdata _ns_flagdata[16] = {
-+ { 0x8000, 15 }, /* qr. */
-+ { 0x7800, 11 }, /* opcode. */
-+ { 0x0400, 10 }, /* aa. */
-+ { 0x0200, 9 }, /* tc. */
-+ { 0x0100, 8 }, /* rd. */
-+ { 0x0080, 7 }, /* ra. */
-+ { 0x0040, 6 }, /* z. */
-+ { 0x0020, 5 }, /* ad. */
-+ { 0x0010, 4 }, /* cd. */
-+ { 0x000f, 0 }, /* rcode. */
-+ { 0x0000, 0 }, /* expansion (1/6). */
-+ { 0x0000, 0 }, /* expansion (2/6). */
-+ { 0x0000, 0 }, /* expansion (3/6). */
-+ { 0x0000, 0 }, /* expansion (4/6). */
-+ { 0x0000, 0 }, /* expansion (5/6). */
-+ { 0x0000, 0 }, /* expansion (6/6). */
-+};
-
- int __ns_msg_getflag(ns_msg handle, int flag) {
- return(((handle)._flags & _ns_flagdata[flag].mask) >> _ns_flagdata[flag].shift);