aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2021-01-13 18:42:59 -0300
committerLeo <thinkabit.ukim@gmail.com>2021-01-14 03:09:07 +0000
commitc611bfce57dd34ff45363fd4e29fba7f6aea8f6b (patch)
tree7a1981f0a29426ac5addbc577a48dba15e0a04ba
parent193eead27bd3153d420269ff4808905887d0d793 (diff)
main/fish: make util-linux a dep of fish-doc and add a README
It is required to have util-linux to use the `help` command in any of the builtins fish provides as the internal `__fish_print_help` function uses the `ul` program that `util-linux` provides. `__fish_print_help` also returns early if there are no manpages installed which are present in `fish-doc` so can we can kludingly deal with this by tying the `util-linux` dependency to the -doc subpackage. This is not perfect as many users that want `fish-doc` don't want `util-linux` but it is better than giving a free `util-linux` dependency to anyone that installs `fish`
-rw-r--r--main/fish/APKBUILD23
-rw-r--r--main/fish/README.alpine1
2 files changed, 12 insertions, 12 deletions
diff --git a/main/fish/APKBUILD b/main/fish/APKBUILD
index ac86cee5720..9945196276a 100644
--- a/main/fish/APKBUILD
+++ b/main/fish/APKBUILD
@@ -2,25 +2,21 @@
# Maintainer: Leo <thinkabit.ukim@gmail.com>
pkgname=fish
pkgver=3.1.2
-pkgrel=3
+pkgrel=4
pkgdesc="Modern interactive commandline shell"
url="http://www.fishshell.com"
arch="all"
license="GPL-2.0-only"
-depends="bc util-linux"
+depends="bc"
+depends_doc="util-linux" # Requires 'ul' program
depends_dev="$pkgname-tools"
makedepends="cmake doxygen ncurses-dev ncurses pcre2-dev"
checkdepends="expect bash"
install="$pkgname.post-install $pkgname.post-upgrade $pkgname.pre-deinstall"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools::noarch"
-source="https://github.com/fish-shell/fish-shell/releases/download/$pkgver/fish-$pkgver.tar.gz"
-
-prepare() {
- default_prepare
- for f in $(find share/tools -type f -name '*.py'); do
- sed -i -e '1{s@^#!.*@#!%{__python3}@}' "$f"
- done
-}
+source="https://github.com/fish-shell/fish-shell/releases/download/$pkgver/fish-$pkgver.tar.gz
+ README.alpine
+ "
build() {
if [ "$CBUILD" != "$CHOST" ]; then
@@ -39,7 +35,6 @@ build() {
}
check() {
- cd builddir
ctest
}
@@ -47,6 +42,9 @@ package() {
make -C builddir install DESTDIR="$pkgdir"
rm -fr "$pkgdir"/usr/share/$pkgname/groff
+ # Install our README
+ install -Dm 644 "$srcdir"/README.alpine -t "$pkgdir"/usr/share/doc/fish
+
mkdir -p "$pkgdir"/usr/lib
mv "$pkgdir"/usr/share/pkgconfig "$pkgdir"/usr/lib
@@ -72,4 +70,5 @@ tools() {
mv "$pkgdir"/usr/share/$pkgname/tools "$subpkgdir"/usr/share/$pkgname
}
-sha512sums="b6ae2c928774a2eaccf35312d3a9446bfa3e1335182c8f2b2d6198161d0916904f4964fb20ed13a5bf850c1c819e003905d13db3bc8b1faa5b401a60b47dc563 fish-3.1.2.tar.gz"
+sha512sums="b6ae2c928774a2eaccf35312d3a9446bfa3e1335182c8f2b2d6198161d0916904f4964fb20ed13a5bf850c1c819e003905d13db3bc8b1faa5b401a60b47dc563 fish-3.1.2.tar.gz
+c28cef48e3d9cde4956d36192dc221e63eca89282a937e2683578ac0958d98a9c54420aea4f1d91d516f5ee2c74589a75865a973305421e1ad0a9e70854dff4f README.alpine"
diff --git a/main/fish/README.alpine b/main/fish/README.alpine
new file mode 100644
index 00000000000..54c9a2eb4cd
--- /dev/null
+++ b/main/fish/README.alpine
@@ -0,0 +1 @@
+To use the `help` command in builtins provided by fish install `fish-doc`