aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-11-02 19:17:14 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-11-02 19:17:14 +0000
commitb857960e86482cf135f84f29033a17eeca2b2b73 (patch)
tree35a0ef006210956981fd315342d8bae75eb58d61
parent4fe4aec9e81e56373876cd229a92f8de3b107e5c (diff)
x11/sdl: upgrade to 1.2.14
-rw-r--r--x11/sdl/APKBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/x11/sdl/APKBUILD b/x11/sdl/APKBUILD
index 41a8107a4ea..e81c8064416 100644
--- a/x11/sdl/APKBUILD
+++ b/x11/sdl/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=sdl
-pkgver=1.2.13
-pkgrel=2
+pkgver=1.2.14
+pkgrel=0
pkgdesc="A library for portable low-level access to a video framebuffer, audio output, mouse, and keyboard"
url="http://www.libsdl.org"
license="LGPL"
@@ -12,8 +12,7 @@ makedepends="libxext-dev libxrender-dev libx11-dev libice-dev libsm-dev
libxrandr-dev mesa-dev alsa-lib-dev libiconv-dev"
source="http://www.libsdl.org/release/SDL-$pkgver.tar.gz"
-build ()
-{
+build() {
cd "$srcdir"/SDL-$pkgver
./configure --prefix=/usr \
--disable-nasm \
@@ -22,8 +21,12 @@ build ()
--with-x \
--disable-rpath \
--disable-nls
- make || return 1
+ make
+}
+
+package() {
+ cd "$srcdir"/SDL-$pkgver
make DESTDIR="$pkgdir" install
}
-md5sums="c6660feea2a6834de10bc71b2f8e4d88 SDL-1.2.13.tar.gz"
+md5sums="e52086d1b508fa0b76c52ee30b55bec4 SDL-1.2.14.tar.gz"