summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2020-10-29 15:02:23 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2020-10-29 15:02:23 +0000
commit8ceca11831a3990a14f92ab6aeb83a4b1d54be2b (patch)
tree7a8ff16722ad6c71454cce1f8e8b7c9240e24c40
parentc3fb176f245b787928c4ee006068bd4735a28d88 (diff)
==== release 3.7.0_rc1 ====3.7.0_rc1
-rw-r--r--Makefile2
-rw-r--r--tests/abuild.bats9
2 files changed, 6 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index e52c3ca6cb5..b526b74134a 100644
--- a/Makefile
+++ b/Makefile
@@ -1,5 +1,5 @@
PACKAGE := abuild
-VERSION := 3.6.0
+VERSION := 3.7.0_rc1
prefix ?= /usr
bindir ?= $(prefix)/bin
diff --git a/tests/abuild.bats b/tests/abuild.bats
index 687bc57347e..d982a89c31d 100644
--- a/tests/abuild.bats
+++ b/tests/abuild.bats
@@ -41,15 +41,16 @@ teardown() {
@test "abuild: verify that packages are reproducible built" {
cd testrepo/pkg1
- $ABUILD
arch=$($ABUILD -A)
pkgs=$($ABUILD listpkg)
- checksums=$( cd "$REPODEST"/testrepo/$arch && md5sum $pkgs)
+
+ $ABUILD
+ checksums=$(cd "$REPODEST"/testrepo/$arch && md5sum $pkgs)
echo "$checksums"
+
$ABUILD cleanpkg all
checksums2=$(cd "$REPODEST"/testrepo/$arch && md5sum $pkgs)
echo "$checksums2"
- [ "$checksums" = "$checksums2" ]
- $ABUILD cleanpkg
+ [ "$checksums" = "$checksums2" ]
}