aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry Romanenko <Dmitry@Romanenko.in>2019-01-08 23:10:15 -0500
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-07-15 09:53:57 +0000
commit247812b0db90fcdc89d8aa9440ddade5ef8368ca (patch)
tree76500c5486fd11e5d2151322985888e22786f7cd
parenta6159bb863488f37c4f8008255e24dd477ba6a38 (diff)
main/py-six: upgrade to 1.12.0, added tests
Needed by py3-fakeredis, see #10548 and https://github.com/benjaminp/six/blob/master/CHANGES Signed-off-by: Leonardo Arena <rnalrd@alpinelinux.org>
-rw-r--r--main/py-six/APKBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/main/py-six/APKBUILD b/main/py-six/APKBUILD
index 5469cb8eb50..405f3b5b71d 100644
--- a/main/py-six/APKBUILD
+++ b/main/py-six/APKBUILD
@@ -2,24 +2,29 @@
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=py-six
_pkgname=six
-pkgver=1.11.0
+pkgver=1.12.0
pkgrel=0
pkgdesc="Python 2 and 3 compatibility library"
url="https://pypi.python.org/pypi/six"
arch="noarch"
license="MIT"
depends=""
+checkdepends="pytest"
makedepends="python2-dev python3-dev py-setuptools"
subpackages="py3-$_pkgname:_py3 py2-$_pkgname:_py2"
source="$pkgname-$pkgver.tar.gz::https://github.com/benjaminp/$_pkgname/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
python2 setup.py build
python3 setup.py build
}
+check() {
+ python2 -m pytest -rfsxX
+ python3 -m pytest -rfsxX
+}
+
package() {
mkdir -p "$pkgdir"
}
@@ -43,4 +48,4 @@ _py3() {
_py python3
}
-sha512sums="f301c6e3c159fc87c121a6b860e4a24fa77ca2d23c3beb29201f7ba0ef71188d683d103fd3f44f50bc774a0682183256ac119e20463d389ebe0f481e2c4711f9 py-six-1.11.0.tar.gz"
+sha512sums="67f218ec591411b4a460e4e2744083b7e128440a50d006433cd85a7485b3f4bbf37830bee4cfd3e24194e4873f9ad251a62900e2f5fce7429d647b3df14543c3 py-six-1.12.0.tar.gz"