aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-09-15 00:12:40 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2017-09-15 00:13:17 +0200
commit5e0bae422954c111f25626d9dc8ce38ce600c5dc (patch)
tree83a3accd3469b782ac178b4691b4eafb29847137
parent2279df977bebcea187595c8e1b5ed5a69139e944 (diff)
community/cloc: forgot to commit updated version of patch
-rw-r--r--community/cloc/APKBUILD4
-rw-r--r--community/cloc/disable-submodule-tests.patch75
2 files changed, 11 insertions, 68 deletions
diff --git a/community/cloc/APKBUILD b/community/cloc/APKBUILD
index 0dce0410f88..2242d8fd8a4 100644
--- a/community/cloc/APKBUILD
+++ b/community/cloc/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=cloc
pkgver=1.74
-pkgrel=0
+pkgrel=1
pkgdesc="Count lines of code"
url="https://github.com/AlDanial/cloc"
arch="noarch"
@@ -32,4 +32,4 @@ package() {
}
sha512sums="456ff10c50673326e0b80d2e0b5965fba19c5c868e880108647d5182e048e62bdd734ce485386a561163d8dab81551101cbc5dcc13088400fe0a14ad500e1cbf cloc-1.74.tar.gz
-0da21579aee7b073dcff93767289e2ae50dbde50fdfd4b5dc36264cc0aa52be1f42b80f18378e264eef5a0c81eb447013343247781bc571f78c226a5c28e93c2 disable-submodule-tests.patch"
+74a9e7db8ebe8194928682882d60fdaef9cb7a5cdadffe8e444f8e7b82338e0c7cb5a3da6b2ac4a2f922bc6a564234ec8426a824d1634db432c9eddd0206c003 disable-submodule-tests.patch"
diff --git a/community/cloc/disable-submodule-tests.patch b/community/cloc/disable-submodule-tests.patch
index 62156da8eda..f4b6c428f43 100644
--- a/community/cloc/disable-submodule-tests.patch
+++ b/community/cloc/disable-submodule-tests.patch
@@ -1,14 +1,10 @@
-These tests don't seem to pass because the tarball doesn't contain a
-.git directory. Therefore we just disable them for now.
-
-diff -upr cloc-1.72.orig/Unix/t/01_opts.t cloc-1.72/Unix/t/01_opts.t
---- cloc-1.72.orig/Unix/t/01_opts.t 2017-04-02 15:47:28.795376867 +0200
-+++ cloc-1.72/Unix/t/01_opts.t 2017-04-02 15:47:46.310296964 +0200
-@@ -64,60 +64,60 @@ my @Tests = (
- 'args' => '--by-file --fullpath --not-match-d bar/bee issues/114',
+diff -upr cloc-1.74.orig/Unix/t/01_opts.t cloc-1.74/Unix/t/01_opts.t
+--- cloc-1.74.orig/Unix/t/01_opts.t 2017-09-15 00:11:50.011466821 +0200
++++ cloc-1.74/Unix/t/01_opts.t 2017-09-15 00:12:12.404939113 +0200
+@@ -65,60 +65,6 @@ my @Tests = (
'ref' => '../tests/outputs/issues/114/T7.yaml',
},
-- {
+ {
- 'name' => 'git submodule handling (github issue #131 T1)',
- 'cd' => '../tests/inputs',
- 'args' => 'issues/131',
@@ -62,60 +58,7 @@ diff -upr cloc-1.72.orig/Unix/t/01_opts.t cloc-1.72/Unix/t/01_opts.t
- 'args' => '--vcs "find foo_bar"',
- 'ref' => '../tests/outputs/issues/147/T1.yaml',
- },
-+ # {
-+ # 'name' => 'git submodule handling (github issue #131 T1)',
-+ # 'cd' => '../tests/inputs',
-+ # 'args' => 'issues/131',
-+ # 'ref' => '../tests/outputs/issues/131/T1.yaml',
-+ # },
-+ # {
-+ # 'name' => 'git submodule handling (github issue #131 T2)',
-+ # 'cd' => '../tests/inputs',
-+ # 'args' => '--vcs git issues/131',
-+ # 'ref' => '../tests/outputs/issues/131/T2.yaml',
-+ # },
-+ # {
-+ # 'name' => 'all files (github issue #132 T1)',
-+ # 'cd' => '../tests/inputs',
-+ # 'args' => 'issues/132',
-+ # 'ref' => '../tests/outputs/issues/132/T1.yaml',
-+ # },
-+ # {
-+ # 'name' => '--vcs git issues/132 (github issue #132 T2)',
-+ # 'cd' => '../tests/inputs',
-+ # 'args' => '--vcs git issues/132',
-+ # 'ref' => '../tests/outputs/issues/132/T2.yaml',
-+ # },
-+ # {
-+ # 'name' => '--vcs-git --exclude-dir ignore_dir (github issue #132 T3)',
-+ # 'cd' => '../tests/inputs/issues/132',
-+ # 'args' => '--vcs git --exclude-dir ignore_dir .',
-+ # 'ref' => '../tests/outputs/issues/132/T3.yaml',
-+ # },
-+ # {
-+ # 'name' => '--vcs git --fullpath --not-match-d issues/132/ignore_dir (github issue #132 T4)',
-+ # 'cd' => '../tests/inputs',
-+ # 'args' => '--vcs git --fullpath --not-match-d issues/132/ignore_dir issues/132',
-+ # 'ref' => '../tests/outputs/issues/132/T4.yaml',
-+ # },
-+ # {
-+ # 'name' => '--vcs git --match-f C-Ansi (github issue #132 T5)',
-+ # 'cd' => '../tests/inputs',
-+ # 'args' => '--vcs git --match-f C-Ansi issues/132',
-+ # 'ref' => '../tests/outputs/issues/132/T5.yaml',
-+ # },
-+ # {
-+ # 'name' => '--vcs git --match-f "\.c$" (github issue #132 T6)',
-+ # 'cd' => '../tests/inputs',
-+ # 'args' => '--vcs git --match-f "\.c$" issues/132',
-+ # 'ref' => '../tests/outputs/issues/132/T6.yaml',
-+ # },
-+ # {
-+ # 'name' => '--vcs "find X" (github issue #147)',
-+ # 'cd' => '../tests/inputs',
-+ # 'args' => '--vcs "find foo_bar"',
-+ # 'ref' => '../tests/outputs/issues/147/T1.yaml',
-+ # },
- );
-
- # Create test input for issue #132 which needs data not in the git repo.
+- {
+ 'name' => '--read-lang-def w/remove_between_general (github issue #166)',
+ 'cd' => '../tests/inputs/issues/166',
+ 'args' => '--read-lang-def X fake.thy',